aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:08 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:33 -0800
commit4201621f4574172aebdadf50fc8c3a7930871aac (patch)
treee4caf7d51f2d1964b0fc1e4de28343c0ccc4444e
parentaaa00e26053c756570b6f2678c3d70ba0a8d20e9 (diff)
downloadmeta-openembedded-contrib-4201621f4574172aebdadf50fc8c3a7930871aac.tar.gz
python3-pyasn1-modules: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest b/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb
index d158876fcd..ccd6025be1 100644
--- a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.3.0.bb
@@ -12,7 +12,7 @@ PYPI_PACKAGE = "pyasn1_modules"
inherit pypi ptest setuptools3
-RDEPENDS:${PN} = "${PYTHON_PN}-pyasn1"
+RDEPENDS:${PN} = "python3-pyasn1"
BBCLASSEXTEND = "native nativesdk"
@@ -21,7 +21,8 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
do_install_ptest() {