aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-11 17:00:25 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-11 11:20:55 -0800
commit168a39d2bf69d547df363443014904a2293eb815 (patch)
treed1267ce9e16530b8f5d7b117c5e7f5bc66e8721f
parent1dda315deacc30018385ce2822c622d88682e92e (diff)
downloadmeta-openembedded-contrib-168a39d2bf69d547df363443014904a2293eb815.tar.gz
meta-*: remove obsolete PYPA_WHEEL and PIP_INSTALL_PACKAGE assignments
These variables are no longer used by pip_install_wheel, so remove them from all recipes that set them. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb2
-rw-r--r--meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb2
-rw-r--r--meta-oe/recipes-devtools/guider/guider_3.9.8.bb1
-rw-r--r--meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb2
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-path_16.4.0.bb1
7 files changed, 0 insertions, 18 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
index ba5d9ac0e6..8e164708ed 100644
--- a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -15,8 +15,6 @@ S = "${WORKDIR}/git"
inherit setuptools3 pkgconfig
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-*-*.whl"
-
RDEPENDS:${PN} = "bluez5"
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
index 53c2ce3d8e..0f66dfd784 100644
--- a/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
+++ b/meta-networking/recipes-devtools/python/python3-scapy_2.4.5.bb
@@ -25,8 +25,6 @@ S = "${WORKDIR}/git"
UPSTREAM_CHECK_COMMITS = "1"
inherit setuptools3 ptest
-PIP_INSTALL_PACKAGE = "scapy"
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-*-*.whl"
do_install:append() {
mv ${D}${bindir}/scapy ${D}${bindir}/scapy3
diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
index c519fa02a3..30d17c84b3 100644
--- a/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
+++ b/meta-oe/recipes-devtools/guider/guider_3.9.8.bb
@@ -14,7 +14,6 @@ SRCREV = "a502cd93b13235b7539557a91328de00b7c51bc3"
S = "${WORKDIR}/git"
inherit setuptools3
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.9.8-*.whl"
RDEPENDS:${PN} = "python3 python3-core \
python3-ctypes python3-shell python3-json"
diff --git a/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb b/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
index e17e773cb4..ec1539b442 100644
--- a/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
+++ b/meta-oe/recipes-devtools/python/python3-apt_2.3.0.bb
@@ -10,8 +10,6 @@ SRCREV = "6145b6484d220685edfd922d364afbf065127efe"
S = "${WORKDIR}/git"
inherit setuptools3
-PIP_INSTALL_PACKAGE = "python_apt"
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.0.0-*.whl"
DEPENDS += "apt"
RDEPENDS:${PN} += "apt python3-core"
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
index d8cb24cab0..ecbfad394d 100644
--- a/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.8.4.bb
@@ -26,9 +26,6 @@ DEPENDS = "libaio util-linux"
inherit setuptools3 useradd
SETUPTOOLS_SETUP_PATH = "${S}/python"
-PIP_INSTALL_DIST_PATH = "${B}/python/dist"
-PIP_INSTALL_PACKAGE = "sanlock_python"
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-3.8.4-*.whl"
do_compile:prepend () {
oe_runmake -C ${S}/wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
diff --git a/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb b/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
index 04493b21d4..7aaf439b83 100644
--- a/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
@@ -7,10 +7,3 @@ PYPI_PACKAGE = "Flask-Versioned"
SRC_URI[sha256sum] = "516694dc860a1bc4f22ab60b324a85083c0150522be109282a3bed681057fd34"
inherit pypi setuptools3
-
-def get_pypa_wheel_name(d):
- return (d.getVar('PIP_INSTALL_DIST_PATH') + '/' + \
- d.getVar('PIP_INSTALL_PACKAGE') + '-' + \
- d.getVar('PV').replace('-', '.post') + '-*.whl')
-
-PYPA_WHEEL = "${@get_pypa_wheel_name(d)}"
diff --git a/meta-python/recipes-devtools/python/python3-path_16.4.0.bb b/meta-python/recipes-devtools/python/python3-path_16.4.0.bb
index 0fc0a33b2b..60ac948cf4 100644
--- a/meta-python/recipes-devtools/python/python3-path_16.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-path_16.4.0.bb
@@ -5,6 +5,5 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
SRC_URI[sha256sum] = "baf2e757c4b19be8208f9e67e48fb475b4a577d5613590ce46693bdbdf082f52"
inherit pypi setuptools_build_meta
-PYPA_WHEEL = "${PIP_INSTALL_DIST_PATH}/${PIP_INSTALL_PACKAGE}-0.0.0-*.whl"
BBCLASSEXTEND = "nativesdk native"