aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-19 16:30:13 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-19 20:19:03 -0800
commit6480f77b2b945ac61e146eeda9e47c11b61a0cbd (patch)
treef3d9e3ecee2003b8707180be586c470da3fa1c9e
parentf3aefa7a78502f636a8465478fdea2b5c4c9aa10 (diff)
downloadmeta-openembedded-contrib-timo/python3-prettytable-update.tar.gz
python3-pytest-lazy-fixture: drop recipetimo/python3-prettytable-update
This recipe is no longer maintained (since 2020) and is not compliant with python3-pytest_8.0.0+. The only dependency in meta-python was the old version of python3-prettytable-ptest, which now RDEPENDS upon python3-pytest-lazy-fixtures (with the s). Drop the recipe Drop it from packagegroup-meta-python Drop it from PTEST_PROBLEMS in ptest-packagelists-meta-python.inc Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb26
4 files changed, 1 insertions, 32 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index fe8f07c851..a9349345bb 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -80,7 +80,6 @@ PTESTS_PROBLEMS_META_PYTHON ="\
python3-ordered-set \
python3-pillow \
python3-pint \
- python3-pytest-lazy-fixture \
python3-pyzmq \
python3-scrypt \
python3-service-identity \
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 41fce53274..eb5a264631 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -348,7 +348,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-pytest-forked \
python3-pytest-helpers-namespace \
python3-pytest-html \
- python3-pytest-lazy-fixture \
+ python3-pytest-lazy-fixtures \
python3-pytest-metadata \
python3-pytest-tempdir \
python3-pytest-timeout \
@@ -507,7 +507,6 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\
python3-pyasn1-modules-ptest \
python3-pyroute2-ptest \
python3-pyserial-ptest \
- python3-pytest-lazy-fixture-ptest \
python3-pytoml-ptest \
python3-pyzmq-ptest \
python3-requests-file-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb b/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb
deleted file mode 100644
index 9c50528fb0..0000000000
--- a/meta-python/recipes-devtools/python/python3-pytest-lazy-fixture_0.6.3.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2022 Wind River Systems
-
-SUMMARY = "Use your fixtures in @pytest.mark.parametrize."
-HOMEPAGE = "https://github.com/tvorog/pytest-lazy-fixture"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=aae6f2b7c9b3ced83e0b5bb42346d4dd"
-
-SRC_URI[sha256sum] = "0e7d0c7f74ba33e6e80905e9bfd81f9d15ef9a790de97993e34213deb5ad10ac"
-
-SRC_URI += "file://run-ptest \
- "
-
-
-inherit ptest pypi setuptools3
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
-
-
-RDEPENDS:${PN} += "python3-core python3-pytest"
-RDEPENDS:${PN}-ptest = " \
- python3-unixadmin \
- python3-unittest-automake-output \
- "