aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-10-02 20:14:07 -0700
committerDaniel McGregor <daniel.mcgregor@vecima.com>2023-10-11 12:57:02 -0600
commit51f568344d85a1400c3014bb0d278f4e2afafd90 (patch)
tree34242e70420f6dbda148cd9f71095be82f987008
parent278c3f75e32f38f71bb52d161fe06bcb6f6bdd2f (diff)
downloadmeta-openembedded-contrib-dankm/nanbield-next.tar.gz
python3-pylint: Upgrade to 3.0.0dankm/nanbield-next
Package additional hidden files for ptests (test_primer.py) Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch53
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch26
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb)5
3 files changed, 2 insertions, 82 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
deleted file mode 100644
index a7637a5ca6..0000000000
--- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001
-From: Trevor Gamblin <tgamblin@baylibre.com>
-Date: Mon, 15 May 2023 09:26:04 -0400
-Subject: [PATCH] pylint: remove plugin pickle test
-
-Upstream-Status: Inappropriate (oe-specific)
-
-Upstream uses an assertion in the removed test to state that the test
-needs changing if the plugin loading succeeds. The same failure wasn't
-seen when running the tests on the host with pytest, so disable it by
-removing the test from the suite.
-
-Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
----
- tests/test_check_parallel.py | 22 ----------------------
- 1 file changed, 22 deletions(-)
-
-diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py
-index d56502eaf..34fec140f 100644
---- a/tests/test_check_parallel.py
-+++ b/tests/test_check_parallel.py
-@@ -257,28 +257,6 @@ class TestCheckParallelFramework:
- assert stats.statement == 18
- assert stats.warning == 0
-
-- def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None:
-- """The linter needs to be pickle-able in order to be passed between workers"""
-- linter = PyLinter(reporter=Reporter())
-- # We load an extension that we know is not pickle-safe
-- linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"])
-- try:
-- dill.dumps(linter)
-- raise AssertionError(
-- "Plugins loaded were pickle-safe! This test needs altering"
-- )
-- except (KeyError, TypeError, PickleError, NotImplementedError):
-- pass
--
-- # And expect this call to make it pickle-able
-- linter.load_plugin_configuration()
-- try:
-- dill.dumps(linter)
-- except KeyError as exc:
-- raise AssertionError(
-- "Cannot pickle linter when using non-pickleable plugin"
-- ) from exc
--
- def test_worker_check_sequential_checker(self) -> None:
- """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker."""
- linter = PyLinter(reporter=Reporter())
---
-2.40.1
-
diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
deleted file mode 100644
index 7950e72077..0000000000
--- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001
-From: Trevor Gamblin <tgamblin@baylibre.com>
-Date: Mon, 1 May 2023 11:32:24 -0400
-Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies
-
-Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
----
-Upstream-Status: Pending
-
- pyproject.toml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pyproject.toml b/pyproject.toml
-index bd542646b..2c0ed9485 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -1,5 +1,5 @@
- [build-system]
--requires = ["setuptools~=62.6", "wheel~=0.37.1"]
-+requires = ["setuptools", "wheel"]
- build-backend = "setuptools.build_meta"
-
- [project]
---
-2.40.0
-
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
index 96fce2e048..413e6599db 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb
@@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
SRC_URI += " \
git://github.com/pylint-dev/pylint;branch=main;protocol=https \
file://run-ptest \
- file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
- file://0001-pylint-remove-plugin-pickle-test.patch \
"
-SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
+SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7"
inherit python_setuptools_build_meta ptest
@@ -47,5 +45,6 @@ S = "${WORKDIR}/git"
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
}