aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-kexecboot_4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-kexecboot_4.4.bb')
-rw-r--r--recipes-kernel/linux/linux-kexecboot_4.4.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-kexecboot_4.4.bb b/recipes-kernel/linux/linux-kexecboot_4.4.bb
index cb3f544..83561a8 100644
--- a/recipes-kernel/linux/linux-kexecboot_4.4.bb
+++ b/recipes-kernel/linux/linux-kexecboot_4.4.bb
@@ -1,5 +1,5 @@
require recipes-kernel/linux/linux-handheld_${PV}.bb
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:${THISDIR}/linux-handheld-${PV}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-${PV}:${THISDIR}/linux-handheld-${PV}:"
SUMMARY = "Linux kernel embedding a minimalistic kexecboot initramfs"
@@ -7,9 +7,6 @@ COMPATIBLE_MACHINE = "|akita|c7x0|collie|poodle|spitz|tosa"
LOCOMO_PATCHES += "file://locomo/0091-locomokbd.c-invert-KEY_ENTER-and-KEY_KPENTER.patch"
-# only for SL-C3200 (terrier)
-# SRC_URI_append_spitz += "file://3200-mtd.patch"
-
# Zaurus machines need kernel size-check.
KERNEL_IMAGE_MAXSIZE_akita = "1264"
KERNEL_IMAGE_MAXSIZE_c7x0 = "1264"
@@ -24,8 +21,8 @@ inherit nopackages
PACKAGES = ""
PROVIDES = ""
-KERNEL_IMAGE_BASE_NAME = "kexecboot-${PV}-${MACHINE}"
-KERNEL_IMAGE_SYMLINK_NAME = "kexecboot-${MACHINE}"
+KERNEL_IMAGE_NAME = "kexecboot-${PV}-${MACHINE}"
+KERNEL_IMAGE_LINK_NAME = "kexecboot-${MACHINE}"
INITRAMFS_IMAGE = "initramfs-kexecboot-klibc-image"
INITRAMFS_TASK = "${INITRAMFS_IMAGE}:do_image_complete"