aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb')
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb b/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb
index c7fbce9..07180c5 100644
--- a/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb
+++ b/recipes-bsp/zaurus-utils/nandlogical_1.0.0.bb
@@ -1,15 +1,20 @@
DESCRIPTION = "Nandlogical for Sharp mtd1"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://nandlogical.c;md5=a734efd470f4d5be324e5d408a1f38a5"
-PR = "r5"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://nandlogical.c;endline=15;md5=77804e7fdf625e56869f32d9aec762a2"
+PR = "r6"
-SRC_URI = "file://nandlogical.c"
+SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/pdaxrom/download/1.1.0beta4/src/survive-1.1.0.tar.bz2 \
+ file://oobblock-to-writesize.patch"
-S = "${WORKDIR}"
+SRC_URI[md5sum] = "b6cb17168a424a5d757309dce4a81841"
+SRC_URI[sha256sum] = "0d02edc12509f6dc98cded37c68238f939c522cbd398fd527785a1e7e3bcfcea"
+
+S = "${WORKDIR}/survive-1.1.0"
do_compile () {
${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
}
+
do_install () {
install -d ${D}${bindir}/
install -m 0755 nandlogical ${D}${bindir}/