aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils/encdec-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/zaurus-utils/encdec-updater.bb')
-rw-r--r--recipes-bsp/zaurus-utils/encdec-updater.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/zaurus-utils/encdec-updater.bb b/recipes-bsp/zaurus-utils/encdec-updater.bb
new file mode 100644
index 0000000..1fa7693
--- /dev/null
+++ b/recipes-bsp/zaurus-utils/encdec-updater.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "file://encdec-updater.c"
+
+do_compile() {
+ ${CC} ${LDFLAGS} -o encdec-updater ${WORKDIR}/encdec-updater.c
+}
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 encdec-updater ${D}${bindir}/
+}
+
+BBCLASSEXTEND = "native"
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|spitz|akita|tosa)"
+
+NATIVE_INSTALL_WORKS = "1"