aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2021-10-05 21:37:25 +0200
committerPaul Eggleton <bluelightning@bluelightning.org>2021-10-06 13:22:30 +1300
commit3fb09263c2f85f7e5d457aa96dc50b8dd3f9d13d (patch)
treea9e03a0b6b1cb7465e204446fddaee191f6f219d /recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
parentade8fd08ae7e325f6c3744570d71cc224991fde6 (diff)
downloadmeta-handheld-3fb09263c2f85f7e5d457aa96dc50b8dd3f9d13d.tar.gz
meta-handheld: convert to new override syntax
-replace old syntax -fix tune files paths now in subdirectories Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <bluelightning@bluelightning.org>
Diffstat (limited to 'recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb')
-rw-r--r--recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb b/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
index 8d97b26..d6d3bc3 100644
--- a/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
+++ b/recipes-kernel/linux/linux-qi-ben-nanonote_3.12.bb
@@ -18,13 +18,13 @@ S = "${WORKDIR}/git"
inherit kernel
-FILES_${KERNEL_PACKAGE_NAME}-image = "/boot/uImage*"
+FILES:${KERNEL_PACKAGE_NAME}-image = "/boot/uImage*"
-do_configure_prepend() {
+do_configure:prepend() {
install -m 0644 ${S}/arch/mips/configs/qi_lb60_defconfig ${S}/.config
}
-do_install_append() {
+do_install:append() {
cd ${S}
kernel_entry=`nm vmlinux | grep " kernel_entry" | cut -d' ' -f1`
@@ -38,10 +38,10 @@ do_install_append() {
install -m 0644 uImage-${KERNEL_VERSION} ${D}/boot
}
-pkg_postinst_kernel() {
+pkg_postinst:kernel() {
cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/uImage uImage uImage-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
}
-pkg_postrm_kernel() {
+pkg_postrm:kernel() {
cd /${KERNEL_IMAGEDEST}; update-alternatives --remove uImage uImage-${KERNEL_VERSION} || true
}