aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2021-10-05 21:37:25 +0200
committerPaul Eggleton <bluelightning@bluelightning.org>2021-10-06 13:22:30 +1300
commit3fb09263c2f85f7e5d457aa96dc50b8dd3f9d13d (patch)
treea9e03a0b6b1cb7465e204446fddaee191f6f219d /recipes-bsp
parentade8fd08ae7e325f6c3744570d71cc224991fde6 (diff)
downloadmeta-handheld-3fb09263c2f85f7e5d457aa96dc50b8dd3f9d13d.tar.gz
meta-handheld: convert to new override syntax
-replace old syntax -fix tune files paths now in subdirectories Signed-off-by: Andrea Adami <andrea.adami@gmail.com> Signed-off-by: Paul Eggleton <bluelightning@bluelightning.org>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/acx-firmware/acx-firmware_1.0.bb2
-rw-r--r--recipes-bsp/formfactor/formfactor_%.bbappend6
-rw-r--r--recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb3
-rw-r--r--recipes-bsp/kbdd/kbdd_svn.bb6
-rw-r--r--recipes-bsp/kexecboot/kexecboot-handhelds.inc12
-rw-r--r--recipes-bsp/kexecboot/kexecboot_%.bbappend2
-rw-r--r--recipes-bsp/keymaps/keymaps_%.bbappend20
-rw-r--r--recipes-bsp/zaurus-utils/nandlogical.bb2
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb4
-rw-r--r--recipes-bsp/zaurusd/zaurusd_git.bb6
10 files changed, 31 insertions, 32 deletions
diff --git a/recipes-bsp/acx-firmware/acx-firmware_1.0.bb b/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
index 3791587..47aca3f 100644
--- a/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
+++ b/recipes-bsp/acx-firmware/acx-firmware_1.0.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://sdgsystems.net/pub/ipaq/hx4700/src/RADIO0d.BIN;name=radio0d \
http://sdgsystems.net/pub/ipaq/hx4700/src/WLANGEN.BIN;name=wlangen "
S = "${WORKDIR}"
-FILES_${PN} = "/lib"
+FILES:${PN} = "/lib"
do_install() {
install -d ${D}/lib/firmware/
diff --git a/recipes-bsp/formfactor/formfactor_%.bbappend b/recipes-bsp/formfactor/formfactor_%.bbappend
index 5c85433..7e26476 100644
--- a/recipes-bsp/formfactor/formfactor_%.bbappend
+++ b/recipes-bsp/formfactor/formfactor_%.bbappend
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-do_install_prepend () {
+do_install:prepend () {
# provide machine-specific /etc/rotation for psplash
sed -n 's/^[ \t]*DISPLAY_ORIENTATION[ \t]*//p' ${S}/machconfig | tr -dc '[0-9]' > ${S}/rotation
}
-do_install_append () {
+do_install:append () {
# Only install file if it has a content
if [ -s "${S}/rotation" ]; then
install -d ${D}${sysconfdir}
diff --git a/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb b/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
index c8ea1d7..649eac6 100644
--- a/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
+++ b/recipes-bsp/ipaq-boot-params/ipaq-boot-params.bb
@@ -13,6 +13,5 @@ do_install() {
install -m 0644 ${WORKDIR}/params ${D}/boot/
}
-FILES_${PN} = "/boot/params"
+FILES:${PN} = "/boot/params"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-bsp/kbdd/kbdd_svn.bb b/recipes-bsp/kbdd/kbdd_svn.bb
index bf99716..381d6f9 100644
--- a/recipes-bsp/kbdd/kbdd_svn.bb
+++ b/recipes-bsp/kbdd/kbdd_svn.bb
@@ -35,15 +35,15 @@ do_install() {
install -m 0644 ${WORKDIR}/kbdd-modules ${D}${sysconfdir}/modutils/
}
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
update-modules
}
-pkg_postrm_${PN} () {
+pkg_postrm:${PN} () {
update-modules
}
INITSCRIPT_NAME = "kbdd"
INITSCRIPT_PARAMS = "defaults"
-RRECOMMENDS_${PN} = "kernel-module-keybdev kernel-module-uinput"
+RRECOMMENDS:${PN} = "kernel-module-keybdev kernel-module-uinput"
diff --git a/recipes-bsp/kexecboot/kexecboot-handhelds.inc b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
index 06bf96d..115138a 100644
--- a/recipes-bsp/kexecboot/kexecboot-handhelds.inc
+++ b/recipes-bsp/kexecboot/kexecboot-handhelds.inc
@@ -1,6 +1,6 @@
-EXTRA_OECONF_akita = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
-EXTRA_OECONF_c7x0 = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
-EXTRA_OECONF_spitz = "--enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
-EXTRA_OECONF_poodle = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
-EXTRA_OECONF_tosa = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
-EXTRA_OECONF_collie = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:akita = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:c7x0 = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:spitz = "--enable-delay=3 --enable-evdev-rate=1000,250 --enable-fbui-width=480 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:poodle = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:tosa = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
+EXTRA_OECONF:collie = "--enable-delay=2 --enable-evdev-rate=1000,250 --enable-bpp=16 --enable-atags --enable-no-checks"
diff --git a/recipes-bsp/kexecboot/kexecboot_%.bbappend b/recipes-bsp/kexecboot/kexecboot_%.bbappend
index 61ba802..e2b3aed 100644
--- a/recipes-bsp/kexecboot/kexecboot_%.bbappend
+++ b/recipes-bsp/kexecboot/kexecboot_%.bbappend
@@ -1,3 +1,3 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
require kexecboot-handhelds.inc
diff --git a/recipes-bsp/keymaps/keymaps_%.bbappend b/recipes-bsp/keymaps/keymaps_%.bbappend
index e9f0159..03ce95b 100644
--- a/recipes-bsp/keymaps/keymaps_%.bbappend
+++ b/recipes-bsp/keymaps/keymaps_%.bbappend
@@ -1,19 +1,19 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI_append_c7x0 = " file://keymap-2.6.map"
-SRC_URI_append_tosa = " file://keymap-2.6.map"
-SRC_URI_append_akita = " file://keymap-2.6.map"
-SRC_URI_append_spitz = " file://keymap-2.6.map"
-SRC_URI_append_collie = " file://keymap-2.6.map"
-SRC_URI_append_poodle = " file://keymap-2.6.map"
-SRC_URI_append_hx4700 = " file://keymap-2.6.map"
+SRC_URI:append:c7x0 = " file://keymap-2.6.map"
+SRC_URI:append:tosa = " file://keymap-2.6.map"
+SRC_URI:append:akita = " file://keymap-2.6.map"
+SRC_URI:append:spitz = " file://keymap-2.6.map"
+SRC_URI:append:collie = " file://keymap-2.6.map"
+SRC_URI:append:poodle = " file://keymap-2.6.map"
+SRC_URI:append:hx4700 = " file://keymap-2.6.map"
# we still use keymap-2.6.map files
-do_configure_append () {
+do_configure:append () {
sed -i -e 's/KERNEL_MAJMIN=.*$/KERNEL_MAJMIN="2.6"/' ${WORKDIR}/keymap.sh
}
-do_install_append () {
+do_install:append () {
case ${MACHINE} in
c7x0 | tosa | akita | spitz | collie | poodle | hx4700 )
install -d ${D}${sysconfdir}
diff --git a/recipes-bsp/zaurus-utils/nandlogical.bb b/recipes-bsp/zaurus-utils/nandlogical.bb
index 12aa326..7965950 100644
--- a/recipes-bsp/zaurus-utils/nandlogical.bb
+++ b/recipes-bsp/zaurus-utils/nandlogical.bb
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:${THISDIR}/files:"
DESCRIPTION = "Nandlogical for Sharp SL FTL reserved partition"
LICENSE = "GPLv2+"
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
index 24d0fe1..4a2604f 100644
--- a/recipes-bsp/zaurus-utils/zaurus-installer.bb
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -3,8 +3,8 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
DEPENDS = "zaurus-updater linux-kexecboot"
-DEPENDS_collie = "linux-kexecboot"
-DEPENDS_append_spitz = " zaurus-legacy-tar"
+DEPENDS:collie = "linux-kexecboot"
+DEPENDS:append:spitz = " zaurus-legacy-tar"
PV = "2017.05"
diff --git a/recipes-bsp/zaurusd/zaurusd_git.bb b/recipes-bsp/zaurusd/zaurusd_git.bb
index 1f8e40b..3109002 100644
--- a/recipes-bsp/zaurusd/zaurusd_git.bb
+++ b/recipes-bsp/zaurusd/zaurusd_git.bb
@@ -32,11 +32,11 @@ S = "${WORKDIR}/git"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_configure_prepend () {
+do_configure:prepend () {
cp ${WORKDIR}/zaurus-hinge.in ${S}/scripts
}
-do_install_append() {
+do_install:append() {
install -d "${D}/etc/zaurusd/hinge-landscape.d"
install -d "${D}/etc/zaurusd/hinge-portrait.d"
install -d "${D}/etc/zaurusd/hinge-close.d"
@@ -59,5 +59,5 @@ inherit autotools-brokensep pkgconfig update-rc.d
INITSCRIPT_NAME = "zaurusd"
INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
-RRECOMMENDS_${PN} += "kernel-module-uinput"
+RRECOMMENDS:${PN} += "kernel-module-uinput"