aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/zaurus-utils/zaurus-installer.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 19:12:32 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 19:12:32 +0100
commitb1cb3dec64aa744280b886927ec476b885c831f5 (patch)
tree7dc4a9b6d7beeaa2f670196a7f52a4a493898165 /recipes-bsp/zaurus-utils/zaurus-installer.bb
downloadmeta-handheld-b1cb3dec64aa744280b886927ec476b885c831f5.tar.gz
initial commit of meta-handheld
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-bsp/zaurus-utils/zaurus-installer.bb')
-rw-r--r--recipes-bsp/zaurus-utils/zaurus-installer.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/zaurus-utils/zaurus-installer.bb b/recipes-bsp/zaurus-utils/zaurus-installer.bb
new file mode 100644
index 0000000..bc345c2
--- /dev/null
+++ b/recipes-bsp/zaurus-utils/zaurus-installer.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Installkit for kexecboot-kernel"
+LICENSE = "zaurus-installer"
+DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
+DEPENDS += "${@base_conditional('MACHINE', 'spitz', 'zaurus-legacy-tar', '', d)}"
+PR = "r4"
+
+do_compile() {
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+
+COMPATIBLE_MACHINE = "(collie|poodle|c7x0|spitz|akita|tosa)"
+
+do_deploy() {
+ cd ${DEPLOY_DIR_IMAGE}
+ rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
+ mkdir installkit-${MACHINE}/
+ [ -f "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
+ if [ ! "${MACHINE}" = "collie" ]; then
+ cp updater.sh installkit-${MACHINE}/updater.sh
+ fi
+ if [ "${MACHINE}" = "spitz" ]; then
+ cp ${DEPLOY_DIR_IMAGE}/gnu-tar installkit-${MACHINE}/gnu-tar
+ fi
+ tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
+ md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
+ rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
+}