aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/keymaps/keymaps_%.bbappend
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2017-03-19 22:35:18 +0100
committerAndrea Adami <andrea.adami@gmail.com>2017-05-14 01:32:14 +0200
commitb18475d4d6af396ea535d485d64b9d95ea5398fa (patch)
tree1ab46c0b40fc4dcfe03ca8308879814c3193aed3 /recipes-bsp/keymaps/keymaps_%.bbappend
parent13b79f31fbf77ecde34ad3b14d572ec28c000cb1 (diff)
downloadmeta-handheld-b18475d4d6af396ea535d485d64b9d95ea5398fa.tar.gz
meta-handheld: use wildcards for the bbappend files
This approach is a little more robust than pinning specific versions from other layers. Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes-bsp/keymaps/keymaps_%.bbappend')
-rw-r--r--recipes-bsp/keymaps/keymaps_%.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/keymaps/keymaps_%.bbappend b/recipes-bsp/keymaps/keymaps_%.bbappend
new file mode 100644
index 0000000..e9f0159
--- /dev/null
+++ b/recipes-bsp/keymaps/keymaps_%.bbappend
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_c7x0 = " file://keymap-2.6.map"
+SRC_URI_append_tosa = " file://keymap-2.6.map"
+SRC_URI_append_akita = " file://keymap-2.6.map"
+SRC_URI_append_spitz = " file://keymap-2.6.map"
+SRC_URI_append_collie = " file://keymap-2.6.map"
+SRC_URI_append_poodle = " file://keymap-2.6.map"
+SRC_URI_append_hx4700 = " file://keymap-2.6.map"
+
+# we still use keymap-2.6.map files
+do_configure_append () {
+ sed -i -e 's/KERNEL_MAJMIN=.*$/KERNEL_MAJMIN="2.6"/' ${WORKDIR}/keymap.sh
+}
+
+do_install_append () {
+ case ${MACHINE} in
+ c7x0 | tosa | akita | spitz | collie | poodle | hx4700 )
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/keymap-*.map ${D}${sysconfdir}
+ ;;
+ *)
+ ;;
+ esac
+}