summaryrefslogtreecommitdiffstats
path: root/trunk/bitbake-ng/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/bitbake-ng/Makefile.am')
-rw-r--r--trunk/bitbake-ng/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/trunk/bitbake-ng/Makefile.am b/trunk/bitbake-ng/Makefile.am
new file mode 100644
index 000000000..fe77f381d
--- /dev/null
+++ b/trunk/bitbake-ng/Makefile.am
@@ -0,0 +1,19 @@
+SUBDIRS = include src tests doc
+
+ACLOCAL_AMFLAGS = -I m4/internal -I m4/external
+AUTOMAKE_OPTIONS = foreign 1.6
+
+MAINT_CLEAN_FILES_AUX = config.guess config.sub depcomp \
+ install-sh missing ltmain.sh \
+ compile mkinstalldirs
+MAINT_CLEAN_FILES_TOP = config.h.in aclocal.m4 \
+ configure Makefile.in stamp-h.in
+MAINT_CLEAN_FILES = $(foreach f,$(MAINT_CLEAN_FILES_TOP),$(top_srcdir)/$(f) $(top_srcdir)/$(f)\~) \
+ $(foreach f,$(MAINT_CLEAN_FILES_AUX),$(auxdir)/$(f) $(auxdir)/$(f)\~)
+
+maintainer-clean-local:
+ rm -f $(MAINT_CLEAN_FILES)
+
+.PHONY: test
+test:
+ @$(MAKE) -C tests $@