summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-20 23:00:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 00:03:54 +0100
commit7d548568a55adfe84a976f2a549995e42da1afef (patch)
treec8c9f8a317d438adeae5a34357247f4586c559d4 /bin
parent43a8319cda7fae37862dae323eeb24cb39ca21b7 (diff)
downloadbitbake-7d548568a55adfe84a976f2a549995e42da1afef.tar.gz
bin/bitbake: Improve exception handling
Due to the internal event processing, this excepting handler usually raises an Empty error, masking the underlying failure. Ensure the original exception is raised. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 0ca82e5a7..5b9294bf4 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -250,7 +250,8 @@ Default BBFILES are the .bb files in the current directory.""")
server.addcooker(cooker)
server.saveConnectionDetails()
- except:
+ except Exception as e:
+ exc_info = sys.exc_info()
while True:
try:
import queue
@@ -262,7 +263,7 @@ Default BBFILES are the .bb files in the current directory.""")
break
if isinstance(event, logging.LogRecord):
logger.handle(event)
- raise
+ raise exc_info[1], None, exc_info[2]
server.detach()
# Should no longer need to ever reference cooker