summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-20 22:54:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-21 00:05:44 +0100
commit35bd5997e8d8e74bc36019030cc10c560a8134f9 (patch)
treed4920bbda13ea03d0f6b6596116454e4a587bab0 /bin
parent7d548568a55adfe84a976f2a549995e42da1afef (diff)
downloadbitbake-35bd5997e8d8e74bc36019030cc10c560a8134f9.tar.gz
bitbake: Create cookerdata splitting config from cooker and bin/bitbake
Currently the UI and server configuration is one big incestuous mess. To start to untangle this we creater cookerdata, a new module which contains various confiuration modules and the code for building the base datastore. To start with we add a ConfigParameters() class which contains information about both the commandline configuration and the original environment. The CookerConfiguration class is created to contain the cooker.configuration options. This means we can transfer new paramters to the server over something like XMLRPC and then build a new configuration from these on the server. Based on a patch from Alexandru Damian <alexandru.damian@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake146
1 files changed, 69 insertions, 77 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 5b9294bf4..7087d2d94 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -39,6 +39,7 @@ import bb.msg
from bb import cooker
from bb import ui
from bb import server
+from bb import cookerdata
__version__ = "1.19.0"
logger = logging.getLogger("BitBake")
@@ -56,16 +57,6 @@ try:
except:
pass
-class BBConfiguration(object):
- """
- Manages build options and configurations for one run
- """
-
- def __init__(self, options):
- for key, val in options.__dict__.items():
- setattr(self, key, val)
- self.pkgs_to_build = []
-
def get_ui(config):
if not config.ui:
@@ -104,94 +95,99 @@ warnings.filterwarnings("ignore", category=ImportWarning)
warnings.filterwarnings("ignore", category=DeprecationWarning, module="<string>$")
warnings.filterwarnings("ignore", message="With-statements now directly support multiple context managers")
+class BitBakeConfigParameters(cookerdata.ConfigParameters):
-def main():
- parser = optparse.OptionParser(
- version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
- usage = """%prog [options] [package ...]
+ def parseCommandLine(self):
+ parser = optparse.OptionParser(
+ version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
+ usage = """%prog [options] [package ...]
-Executes the specified task (default is 'build') for a given set of BitBake files.
-It expects that BBFILES is defined, which is a space separated list of files to
-be executed. BBFILES does support wildcards.
-Default BBFILES are the .bb files in the current directory.""")
+ Executes the specified task (default is 'build') for a given set of BitBake files.
+ It expects that BBFILES is defined, which is a space separated list of files to
+ be executed. BBFILES does support wildcards.
+ Default BBFILES are the .bb files in the current directory.""")
- parser.add_option("-b", "--buildfile", help = "execute the task against this .bb file, rather than a package from BBFILES. Does not handle any dependencies.",
- action = "store", dest = "buildfile", default = None)
+ parser.add_option("-b", "--buildfile", help = "execute the task against this .bb file, rather than a package from BBFILES. Does not handle any dependencies.",
+ action = "store", dest = "buildfile", default = None)
- parser.add_option("-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",
- action = "store_false", dest = "abort", default = True)
+ parser.add_option("-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",
+ action = "store_false", dest = "abort", default = True)
- parser.add_option("-a", "--tryaltconfigs", help = "continue with builds by trying to use alternative providers where possible.",
- action = "store_true", dest = "tryaltconfigs", default = False)
+ parser.add_option("-a", "--tryaltconfigs", help = "continue with builds by trying to use alternative providers where possible.",
+ action = "store_true", dest = "tryaltconfigs", default = False)
- parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
- action = "store_true", dest = "force", default = False)
+ parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
+ action = "store_true", dest = "force", default = False)
- parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
- action = "store", dest = "cmd")
+ parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
+ action = "store", dest = "cmd")
- parser.add_option("-C", "--clear-stamp", help = "Invalidate the stamp for the specified cmd such as 'compile' and run the default task for the specified target(s)",
- action = "store", dest = "invalidate_stamp")
+ parser.add_option("-C", "--clear-stamp", help = "Invalidate the stamp for the specified cmd such as 'compile' and run the default task for the specified target(s)",
+ action = "store", dest = "invalidate_stamp")
- parser.add_option("-r", "--read", help = "read the specified file before bitbake.conf",
- action = "append", dest = "prefile", default = [])
+ parser.add_option("-r", "--read", help = "read the specified file before bitbake.conf",
+ action = "append", dest = "prefile", default = [])
- parser.add_option("-R", "--postread", help = "read the specified file after bitbake.conf",
- action = "append", dest = "postfile", default = [])
+ parser.add_option("-R", "--postread", help = "read the specified file after bitbake.conf",
+ action = "append", dest = "postfile", default = [])
- parser.add_option("-v", "--verbose", help = "output more chit-chat to the terminal",
- action = "store_true", dest = "verbose", default = False)
+ parser.add_option("-v", "--verbose", help = "output more chit-chat to the terminal",
+ action = "store_true", dest = "verbose", default = False)
- parser.add_option("-D", "--debug", help = "Increase the debug level. You can specify this more than once.",
- action = "count", dest="debug", default = 0)
+ parser.add_option("-D", "--debug", help = "Increase the debug level. You can specify this more than once.",
+ action = "count", dest="debug", default = 0)
- parser.add_option("-n", "--dry-run", help = "don't execute, just go through the motions",
- action = "store_true", dest = "dry_run", default = False)
+ parser.add_option("-n", "--dry-run", help = "don't execute, just go through the motions",
+ action = "store_true", dest = "dry_run", default = False)
- parser.add_option("-S", "--dump-signatures", help = "don't execute, just dump out the signature construction information",
- action = "store_true", dest = "dump_signatures", default = False)
+ parser.add_option("-S", "--dump-signatures", help = "don't execute, just dump out the signature construction information",
+ action = "store_true", dest = "dump_signatures", default = False)
- parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
- action = "store_true", dest = "parse_only", default = False)
+ parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
+ action = "store_true", dest = "parse_only", default = False)
- parser.add_option("-s", "--show-versions", help = "show current and preferred versions of all recipes",
- action = "store_true", dest = "show_versions", default = False)
+ parser.add_option("-s", "--show-versions", help = "show current and preferred versions of all recipes",
+ action = "store_true", dest = "show_versions", default = False)
- parser.add_option("-e", "--environment", help = "show the global or per-package environment (this is what used to be bbread)",
- action = "store_true", dest = "show_environment", default = False)
+ parser.add_option("-e", "--environment", help = "show the global or per-package environment (this is what used to be bbread)",
+ action = "store_true", dest = "show_environment", default = False)
- parser.add_option("-g", "--graphviz", help = "emit the dependency trees of the specified packages in the dot syntax, and the pn-buildlist to show the build list",
- action = "store_true", dest = "dot_graph", default = False)
+ parser.add_option("-g", "--graphviz", help = "emit the dependency trees of the specified packages in the dot syntax, and the pn-buildlist to show the build list",
+ action = "store_true", dest = "dot_graph", default = False)
- parser.add_option("-I", "--ignore-deps", help = """Assume these dependencies don't exist and are already provided (equivalent to ASSUME_PROVIDED). Useful to make dependency graphs more appealing""",
- action = "append", dest = "extra_assume_provided", default = [])
+ parser.add_option("-I", "--ignore-deps", help = """Assume these dependencies don't exist and are already provided (equivalent to ASSUME_PROVIDED). Useful to make dependency graphs more appealing""",
+ action = "append", dest = "extra_assume_provided", default = [])
- parser.add_option("-l", "--log-domains", help = """Show debug logging for the specified logging domains""",
- action = "append", dest = "debug_domains", default = [])
+ parser.add_option("-l", "--log-domains", help = """Show debug logging for the specified logging domains""",
+ action = "append", dest = "debug_domains", default = [])
- parser.add_option("-P", "--profile", help = "profile the command and print a report",
- action = "store_true", dest = "profile", default = False)
+ parser.add_option("-P", "--profile", help = "profile the command and print a report",
+ action = "store_true", dest = "profile", default = False)
- parser.add_option("-u", "--ui", help = "userinterface to use",
- action = "store", dest = "ui")
+ parser.add_option("-u", "--ui", help = "userinterface to use",
+ action = "store", dest = "ui")
- parser.add_option("-t", "--servertype", help = "Choose which server to use, none, process or xmlrpc",
- action = "store", dest = "servertype")
+ parser.add_option("-t", "--servertype", help = "Choose which server to use, none, process or xmlrpc",
+ action = "store", dest = "servertype")
- parser.add_option("", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not",
- action = "store_true", dest = "revisions_changed", default = False)
+ parser.add_option("", "--revisions-changed", help = "Set the exit code depending on whether upstream floating revisions have changed or not",
+ action = "store_true", dest = "revisions_changed", default = False)
- parser.add_option("", "--server-only", help = "Run bitbake without UI, the frontend can connect with bitbake server itself",
- action = "store_true", dest = "server_only", default = False)
+ parser.add_option("", "--server-only", help = "Run bitbake without UI, the frontend can connect with bitbake server itself",
+ action = "store_true", dest = "server_only", default = False)
- parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to",
- action = "store", dest = "bind", default = False)
- parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks, forces builds",
- action = "store_true", dest = "nosetscene", default = False)
- options, args = parser.parse_args(sys.argv)
+ parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to",
+ action = "store", dest = "bind", default = False)
+ parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks, forces builds",
+ action = "store_true", dest = "nosetscene", default = False)
+ options, targets = parser.parse_args(sys.argv)
+ return options, targets[1:]
- configuration = BBConfiguration(options)
- configuration.pkgs_to_build.extend(args[1:])
+def main():
+
+ configParams = BitBakeConfigParameters()
+ configuration = cookerdata.CookerConfiguration()
+ configuration.setConfigParameters(configParams)
ui_main = get_ui(configuration)
@@ -230,9 +226,6 @@ Default BBFILES are the .bb files in the current directory.""")
handler = bb.event.LogHandler()
logger.addHandler(handler)
- # Before we start modifying the environment we should take a pristine
- # copy for possible later use
- initialenv = os.environ.copy()
# Clear away any spurious environment variables while we stoke up the cooker
cleanedvars = bb.utils.clean_environment()
@@ -242,10 +235,9 @@ Default BBFILES are the .bb files in the current directory.""")
else:
server.initServer()
- idle = server.getServerIdleCB()
-
try:
- cooker = bb.cooker.BBCooker(configuration, idle, initialenv)
+ configuration.setServerRegIdleCallback(server.getServerIdleCB())
+ cooker = bb.cooker.BBCooker(configuration)
cooker.parseCommandLine()
server.addcooker(cooker)