summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-09-03 10:28:01 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-04 14:18:38 +0100
commit8757f962b92e7668f40d2d8bd9e762b152f91f7b (patch)
treeede51d2fddc45cb641dd39e4e37a3120b828855e
parent92940b0427d9b2b3f95e27c230ec1e36638a34bc (diff)
downloadbitbake-8757f962b92e7668f40d2d8bd9e762b152f91f7b.tar.gz
hob: remove PACKAGE_INSTALL variable setting from hob
Before saving the packages for a custom images in a .bb file, the packages were saved in bitbake memory. Now all the variables are saved in conf file, so saving PACKAGE_INSTALL is not needed anymore. Moved were LINGUAS_INSTALL is set, because both conditions are for testing if a custom image is saved. [YOCTO #5101] Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/ui/crumbs/hobeventhandler.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/lib/bb/ui/crumbs/hobeventhandler.py b/lib/bb/ui/crumbs/hobeventhandler.py
index 7854742d4..d0ac6bd67 100644
--- a/lib/bb/ui/crumbs/hobeventhandler.py
+++ b/lib/bb/ui/crumbs/hobeventhandler.py
@@ -166,13 +166,11 @@ class HobHandler(gobject.GObject):
self.clear_busy()
self.building = True
targets = [self.image]
- if self.package_queue:
- self.set_var_in_file("LINGUAS_INSTALL", "", "local.conf")
- self.set_var_in_file("PACKAGE_INSTALL", " ".join(self.package_queue), "local.conf")
if self.toolchain_packages:
self.set_var_in_file("TOOLCHAIN_TARGET_TASK", " ".join(self.toolchain_packages), "local.conf")
targets.append(self.toolchain)
if targets[0] == "hob-image":
+ self.set_var_in_file("LINGUAS_INSTALL", "", "local.conf")
hobImage = self.runCommand(["matchFile", "hob-image.bb"])
if self.base_image != "Start with an empty image recipe":
baseImage = self.runCommand(["matchFile", self.base_image + ".bb"])