aboutsummaryrefslogtreecommitgenerated by cgit 1.2.3-korg (git 2.39.0) at 2024-09-24 18:32:25 +0000 #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
inherit src_distribute

# SRC_DIST_LOCAL possible values:
# copy		copies the files from ${A} to the distributedir
# symlink	symlinks the files from ${A} to the distributedir
# move+symlink	moves the files into distributedir, and symlinks them back
SRC_DIST_LOCAL ?= "move+symlink"
SRC_DISTRIBUTEDIR ?= "${DEPLOY_DIR}/sources"
SRC_DISTRIBUTECOMMAND () {
	s="${SRC}"
	if [ ! -L "$s" ] && (echo "$s"|grep "^${DL_DIR}"); then
		:
	else
		exit 0;
	fi
	mkdir -p ${SRC_DISTRIBUTEDIR}
	case "${SRC_DIST_LOCAL}" in
		copy)
			test -e $s.md5 && cp -f $s.md5 ${SRC_DISTRIBUTEDIR}/
			cp -f $s ${SRC_DISTRIBUTEDIR}/
			;;
		symlink)
			test -e $s.md5 && ln -sf $s.md5 ${SRC_DISTRIBUTEDIR}/
			ln -sf $s ${SRC_DISTRIBUTEDIR}/
			;;
		move+symlink)
			mv $s ${SRC_DISTRIBUTEDIR}/
			ln -sf ${SRC_DISTRIBUTEDIR}/`basename $s` $s
			;;
	esac
}