aboutsummaryrefslogtreecommitdiffstats
path: root/sqlite/sqlite3-3.0.8/cross-compile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sqlite/sqlite3-3.0.8/cross-compile.patch')
-rw-r--r--sqlite/sqlite3-3.0.8/cross-compile.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/sqlite/sqlite3-3.0.8/cross-compile.patch b/sqlite/sqlite3-3.0.8/cross-compile.patch
index e69de29bb2..36afa8e70b 100644
--- a/sqlite/sqlite3-3.0.8/cross-compile.patch
+++ b/sqlite/sqlite3-3.0.8/cross-compile.patch
@@ -0,0 +1,109 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- sqlite/configure.ac~cross-compile
++++ sqlite/configure.ac
+@@ -202,10 +202,11 @@
+ default_build_cflags="-g"
+ if test "$config_BUILD_CC" = ""; then
+ AC_PROG_CC
+- if test "$cross_compiling" = "yes"; then
+- AC_MSG_ERROR([unable to find a compiler for building build tools])
+- fi
+- BUILD_CC=$CC
++# if test "$cross_compiling" = "yes"; then
++# AC_MSG_ERROR([unable to find a compiler for building build tools])
++# fi
++# BUILD_CC=$CC
++ BUILD_CC=gcc
+ default_build_cflags=$CFLAGS
+ else
+ BUILD_CC=$config_BUILD_CC
+@@ -412,25 +413,7 @@
+ ##########
+ # Figure out what C libraries are required to compile Tcl programs.
+ #
+-if test "$config_TARGET_TCL_LIBS" != ""; then
+- TARGET_TCL_LIBS="$config_TARGET_TCL_LIBS"
+-else
+- if test "$with_tcl" != ""; then
+- extra=`echo $with_tcl/$tclsubdir/libtcl8*.a`
+- fi
+- CC=$TARGET_CC
+- AC_CHECK_FUNC(sin, LIBS="", LIBS="-lm")
+- AC_CHECK_LIB(dl, dlopen)
+- otherlibs=$LIBS
+- if test "$extra" != ""; then
+- LIBS=$extra
+- else
+- LIBS=""
+- AC_SEARCH_LIBS(Tcl_Init, dnl
+- tcl8.4 tcl8.3 tcl84 tcl83 tcl,,,$otherlibs)
+- fi
+- TARGET_TCL_LIBS="$LIBS $otherlibs"
+-fi
++TARGET_TCL_INC="-DNO_TCL=1"
+ AC_SUBST(TARGET_TCL_LIBS)
+
+ ##########
+@@ -474,55 +457,14 @@
+ # Figure out what C libraries are required to compile programs
+ # that use "readline()" library.
+ #
+-if test "$config_TARGET_READLINE_LIBS" != ""; then
+- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
+-else
+- CC=$TARGET_CC
+- LIBS=""
+- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
+- AC_CHECK_LIB([readline], [readline])
+- TARGET_READLINE_LIBS="$LIBS"
+-fi
++TARGET_READLINE_LIBS="-lreadline"
+ AC_SUBST(TARGET_READLINE_LIBS)
+
+ ##########
+ # Figure out where to get the READLINE header files.
+ #
+-AC_MSG_CHECKING([readline header files])
+-found=no
+-if test "$config_TARGET_READLINE_INC" != ""; then
+- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
+- found=yes
+-fi
+-if test "$found" = "yes"; then
+- AC_MSG_RESULT($TARGET_READLINE_INC)
+-else
+- AC_MSG_RESULT(not specified: still searching...)
+- AC_CHECK_HEADER(readline.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
+- AC_CHECK_FILE($dir/include/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include"
+- break
+- fi
+- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include/readline"
+- break
+- fi
+- done
+-fi
+-if test "$found" = "yes"; then
+- if test "$TARGET_READLINE_LIBS" = ""; then
+- TARGET_HAVE_READLINE=0
+- else
+- TARGET_HAVE_READLINE=1
+- fi
+-else
+- TARGET_HAVE_READLINE=0
+-fi
++TARGET_READLINE_INC=""
++TARGET_HAVE_READLINE=1
+ AC_SUBST(TARGET_READLINE_INC)
+ AC_SUBST(TARGET_HAVE_READLINE)
+