aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-utils/zaurus-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zaurus-utils/zaurus-updater.bb')
-rw-r--r--recipes/zaurus-utils/zaurus-updater.bb36
1 files changed, 16 insertions, 20 deletions
diff --git a/recipes/zaurus-utils/zaurus-updater.bb b/recipes/zaurus-utils/zaurus-updater.bb
index 7621d47e20..ee41182cdb 100644
--- a/recipes/zaurus-utils/zaurus-updater.bb
+++ b/recipes/zaurus-utils/zaurus-updater.bb
@@ -1,39 +1,35 @@
DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
DEPENDS = "encdec-updater-native"
LICENSE = "zaurus-updater"
-PR = "r24"
+PR = "r25"
-PACKAGES = ""
+# even though the package is not machine-specific
+# we have to force it there to allow multimachine builds
+# because DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE}"
+# and without this only the first machine built get the right staging ipk
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PACKAGES = ""
COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
-SRC_URI = "file://updater.sh \
- file://gnu-tar.gz"
+SRC_URI = "file://updater.sh"
+
S = "${WORKDIR}"
do_configure() {
- sed -i "s/ZAURUS_UPDATER_VERSION/${PR}/" "${S}/updater.sh"
+ sed -i "s/ZAURUS_UPDATER_VERSION/${PR}/" "${S}/updater.sh"
}
do_compile() {
- encdec-updater -e updater.sh
+ encdec-updater -e updater.sh
}
do_deploy() {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh.${MACHINE}
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh.${MACHINE}
-
- case ${MACHINE} in
- spitz )
- install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
- package_stagefile_shell ${DEPLOY_DIR_IMAGE}/gnu-tar
- ;;
- *)
- ;;
- esac
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh
}
-# package_stagefile_shell need to run before populate_staging for packaged-staging
-addtask deploy before do_populate_staging after do_compile
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile