aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zaurus-utils/zaurus-legacy-tar.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zaurus-utils/zaurus-legacy-tar.bb')
-rw-r--r--recipes/zaurus-utils/zaurus-legacy-tar.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/zaurus-utils/zaurus-legacy-tar.bb b/recipes/zaurus-utils/zaurus-legacy-tar.bb
new file mode 100644
index 0000000000..00d6cce2f0
--- /dev/null
+++ b/recipes/zaurus-utils/zaurus-legacy-tar.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Legacy GNU-tar to unpack hd images on install for Zaurus spitz"
+LICENSE = "GPL"
+PR = "r0"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+COMPATIBLE_MACHINE = "spitz"
+
+SRC_URI = "file://gnu-tar.gz"
+
+S = "${WORKDIR}"
+
+do_compile() {
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/gnu-tar
+}
+
+# package_stagefile_shell needs to run before populate_staging for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile