aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xstroke
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xstroke')
-rw-r--r--recipes/xstroke/xstroke-0.6/auto-disable.patch20
-rw-r--r--recipes/xstroke/xstroke_0.6.bb11
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xstroke/xstroke-0.6/auto-disable.patch b/recipes/xstroke/xstroke-0.6/auto-disable.patch
new file mode 100644
index 0000000000..693460cad9
--- /dev/null
+++ b/recipes/xstroke/xstroke-0.6/auto-disable.patch
@@ -0,0 +1,20 @@
+Index: control_win.c
+===================================================================
+RCS file: /cvs/xstroke/xstroke/control_win.c,v
+retrieving revision 1.21
+diff -u -r1.21 control_win.c
+--- control_win.c 28 Sep 2003 11:53:42 -0000 1.21
++++ control_win.c 24 Jul 2004 15:02:52 -0000
+@@ -646,9 +646,11 @@
+ if (XGetWindowAttributes(dpy, window, &attr)) {
+ if (attr.all_event_masks & (KeyPressMask | KeyReleaseMask)) {
+ return 1;
++ } else if (attr.all_event_masks & PointerMotionMask) {
++ return 0;
+ }
+ }
+- return 0;
++ return 1;
+ }
+
+ /*
diff --git a/recipes/xstroke/xstroke_0.6.bb b/recipes/xstroke/xstroke_0.6.bb
new file mode 100644
index 0000000000..7e0d11cc98
--- /dev/null
+++ b/recipes/xstroke/xstroke_0.6.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Gesture recognition input method for X11"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 xft libxtst libxpm"
+PR = "r2"
+
+SRC_URI = "http://www.oesources.org/source/current/xstroke-0.6.tar.gz \
+ file://auto-disable.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig