aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-xserver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xorg-xserver')
-rw-r--r--recipes/xorg-xserver/xorg-xserver-common.inc6
-rw-r--r--recipes/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb4
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/om-gta02/xorg.conf52
-rw-r--r--recipes/xorg-xserver/xserver-xorg/dolt-fix-1.7.0.patch22
-rw-r--r--recipes/xorg-xserver/xserver-xorg/randr-support-1.7.0.patch96
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.1.bb19
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.2.bb19
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.3.bb19
8 files changed, 223 insertions, 14 deletions
diff --git a/recipes/xorg-xserver/xorg-xserver-common.inc b/recipes/xorg-xserver/xorg-xserver-common.inc
index 437ab2fddc..a2a95b74cf 100644
--- a/recipes/xorg-xserver/xorg-xserver-common.inc
+++ b/recipes/xorg-xserver/xorg-xserver-common.inc
@@ -2,7 +2,7 @@ HOMEPAGE = "http://www.x.org"
SECTION = "x11/base"
LICENSE = "MIT-X"
-INC_PR = "r12"
+INC_PR = "r13"
PROVIDES = "virtual/xserver"
@@ -47,7 +47,7 @@ FILES_${PN}-sdl = "${bindir}/Xsdl"
FILES_${PN}-xprint = "${libdir}/X11/xserver/*/print"
FILES_${PN}-xvfb = "${bindir}/Xvfb"
FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
-FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/modules ${libdir}/xorg/modules /etc/X11 "
+FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/modules ${libdir}/xorg/modules /etc/X11 ${libdir}/xorg/protocol.txt"
FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
FILES_${PN}-xephyr = "${bindir}/Xephyr"
@@ -67,6 +67,7 @@ FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
# 84.0k libxf4bpp.so
PACKAGES =+ "${PN}-extension-dri \
+ ${PN}-extension-dri2 \
${PN}-extension-glx \
${PN}-module-libint10 \
${PN}-module-libafb \
@@ -78,6 +79,7 @@ PACKAGES =+ "${PN}-extension-dri \
${PN}-module-libxf4bpp"
FILES_${PN}-extension-dri = "${libdir}/xorg/modules/extensions/libdri.so"
+FILES_${PN}-extension-dri2 = "${libdir}/xorg/modules/extensions/libdri2.so"
FILES_${PN}-extension-glx = "${libdir}/xorg/modules/extensions/libglx.so"
FILES_${PN}-module-libint10 = "${libdir}/xorg/modules/libint10.so"
FILES_${PN}-module-libafb = "${libdir}/xorg/modules/libafb.so"
diff --git a/recipes/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb b/recipes/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
index 614848f3e3..40b6fe8c3f 100644
--- a/recipes/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
+++ b/recipes/xorg-xserver/xserver-kdrive-glamo_1.3.0.0+git.bb
@@ -9,8 +9,8 @@ DEPENDS += "libxkbfile libxcalibrate"
RDEPENDS_${PN} = "xserver-security-policy"
PROVIDES = "virtual/xserver"
-PE = "1"
-PV = "1.3.0.0+gitr${SRCREV}"
+PE = "2"
+PV = "1.3.0.0+gitr${SRCPV}"
PR = "r3"
COMPATIBLE_HOST = "arm.*-linux"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/om-gta02/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/om-gta02/xorg.conf
index 3fc8d83b22..7d7589fd6c 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf/om-gta02/xorg.conf
+++ b/recipes/xorg-xserver/xserver-xorg-conf/om-gta02/xorg.conf
@@ -1,20 +1,52 @@
+Section "Module"
+ Load "glx"
+ Load "dri2"
+EndSection
+
+
Section "Monitor"
- Identifier "Builtin Default Monitor"
+ Identifier "LCD Panel"
EndSection
+
Section "Device"
- Identifier "Builtin Default glamo Device 0"
- Driver "glamo"
-EndSection
+ Identifier "Glamo Graphics Chip"
+ Driver "glamo"
+EndSection
+
Section "Screen"
- Identifier "Builtin Default glamo Screen 0"
- Device "Builtin Default glamo Device 0"
- Monitor "Builtin Default Monitor"
+ Identifier "Default Screen"
+ Device "Glamo Graphics Chip"
+ Monitor "LCD Panel"
EndSection
-Section "ServerLayout"
- Identifier "Builtin Default Layout"
- Screen "Builtin Default glamo Screen 0"
+
+Section "InputDevice"
+ Identifier "Power Button"
+ Driver "evdev"
+ Option "Device" "/dev/input/event0"
EndSection
+
+Section "InputDevice"
+ Identifier "AUX Button"
+ Driver "evdev"
+ Option "Device" "/dev/input/event4"
+EndSection
+
+
+Section "InputDevice"
+ Identifier "Touchscreen"
+ Driver "evdev"
+ Option "Device" "/dev/input/event1"
+EndSection
+
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen "Default Screen"
+ InputDevice "Power Button"
+ InputDevice "AUX Button"
+ InputDevice "Touchscreen"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg/dolt-fix-1.7.0.patch b/recipes/xorg-xserver/xserver-xorg/dolt-fix-1.7.0.patch
new file mode 100644
index 0000000000..e332ce0bbe
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg/dolt-fix-1.7.0.patch
@@ -0,0 +1,22 @@
+Index: xorg-server/m4/dolt.m4
+===================================================================
+--- xorg-server.orig/m4/dolt.m4 2009-04-14 21:14:56.000000000 +0400
++++ xorg-server/m4/dolt.m4 2009-07-15 12:38:33.796848843 +0400
+@@ -147,7 +147,7 @@
+ cat <<__DOLTLIBTOOL__EOF__ > doltlibtool
+ #!$DOLT_BASH
+ __DOLTLIBTOOL__EOF__
+- cat <<'__DOLTLIBTOOL__EOF__' >>doltlibtool
++ cat <<'__DOLTLIBTOOL__EOF__' | sed -e "s/@host_alias@/$host_alias/g" >>doltlibtool
+ top_builddir_slash="${0%%doltlibtool}"
+ : ${top_builddir_slash:=./}
+ args=()
+@@ -163,7 +163,7 @@
+ if $modeok && $tagok ; then
+ . ${top_builddir_slash}doltcompile "${args@<:@@@:>@}"
+ else
+- exec ${top_builddir_slash}libtool "$[]@"
++ exec ${top_builddir_slash}@host_alias@-libtool "$[]@"
+ fi
+ __DOLTLIBTOOL__EOF__
+
diff --git a/recipes/xorg-xserver/xserver-xorg/randr-support-1.7.0.patch b/recipes/xorg-xserver/xserver-xorg/randr-support-1.7.0.patch
new file mode 100644
index 0000000000..fb8d3815be
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg/randr-support-1.7.0.patch
@@ -0,0 +1,96 @@
+diff -Nur xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c
+--- xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c 2009-09-24 07:12:00.000000000 +0200
++++ xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c 2009-10-08 11:45:50.000000000 +0200
+@@ -95,6 +95,8 @@
+
+ #include "os.h"
+
++#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
++
+ EventListPtr xf86Events = NULL;
+
+ /**
+@@ -1086,4 +1088,67 @@
+ EnableDevice(dev, TRUE);
+ }
+
++/* Taken from evdev-properties.h. */
++#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
++#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
++
++/* This is a hack until we get device -> CRTC association. */
++void
++xf86InputRotationNotify(Rotation rotation)
++{
++ DeviceIntPtr dev;
++ LocalDevicePtr local;
++ int ret;
++ int swap_axes = 0;
++ CARD8 invert[2] = { 0, 0 };
++ static Atom prop_swap = 0, prop_invert = 0;
++ static int atom_generation = -1;
++
++ if (atom_generation != serverGeneration) {
++ prop_swap = 0;
++ prop_invert = 0;
++ }
++
++ switch (rotation & RR_Rotate_All) {
++ case RR_Rotate_0:
++ break;
++ case RR_Rotate_90:
++ swap_axes = 1;
++ invert[0] = 1;
++ break;
++ case RR_Rotate_180:
++ invert[0] = 1;
++ invert[1] = 1;
++ break;
++ case RR_Rotate_270:
++ swap_axes = 1;
++ invert[1] = 1;
++ break;
++ }
++
++ if (!prop_swap)
++ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
++ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
++ if (!prop_invert)
++ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
++ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
++
++ for (dev = inputInfo.devices; dev; dev = dev->next) {
++ local = dev->public.devicePrivate;
++ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
++ PropModeReplace, 1, &swap_axes, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
++ continue;
++ }
++ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
++ PropModeReplace, 2, invert, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing invert property failed!\n");
++ continue;
++ }
++ }
++}
++
++
+ /* end of xf86Xinput.c */
+diff -Nur xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c
+--- xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c 2009-10-01 08:27:36.000000000 +0200
++++ xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c 2009-10-08 11:28:42.000000000 +0200
+@@ -391,6 +391,12 @@
+ if (didLock)
+ crtc->funcs->unlock (crtc);
+
++ /*
++ * Rotate Touchscreen
++ */
++ xf86InputRotationNotify(crtc->rotation);
++
++
+ return ret;
+ }
+
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.1.bb b/recipes/xorg-xserver/xserver-xorg_1.7.1.bb
new file mode 100644
index 0000000000..8f72741387
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.7.1.bb
@@ -0,0 +1,19 @@
+require xorg-xserver-common.inc
+
+DESCRIPTION = "the X.Org X server"
+DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
+PE = "2"
+PR = "r1"
+
+SRC_URI += "file://sysroot_fix.patch;patch=1 \
+ file://dolt-fix-1.7.0.patch;patch=1 \
+ file://randr-support-1.7.0.patch;patch=1 \
+ "
+do_install_prepend() {
+ mkdir -p ${D}/${libdir}/X11/fonts
+}
+
+EXTRA_OECONF += "--disable-xephyr --disable-config-hal --disable-xinerama --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
+EXTRA_OECONF += " --disable-glx-tls --enable-dri2 --disable-unit-tests "
+
+export LDFLAGS += " -ldl "
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.2.bb b/recipes/xorg-xserver/xserver-xorg_1.7.2.bb
new file mode 100644
index 0000000000..8f72741387
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.7.2.bb
@@ -0,0 +1,19 @@
+require xorg-xserver-common.inc
+
+DESCRIPTION = "the X.Org X server"
+DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
+PE = "2"
+PR = "r1"
+
+SRC_URI += "file://sysroot_fix.patch;patch=1 \
+ file://dolt-fix-1.7.0.patch;patch=1 \
+ file://randr-support-1.7.0.patch;patch=1 \
+ "
+do_install_prepend() {
+ mkdir -p ${D}/${libdir}/X11/fonts
+}
+
+EXTRA_OECONF += "--disable-xephyr --disable-config-hal --disable-xinerama --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
+EXTRA_OECONF += " --disable-glx-tls --enable-dri2 --disable-unit-tests "
+
+export LDFLAGS += " -ldl "
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.3.bb b/recipes/xorg-xserver/xserver-xorg_1.7.3.bb
new file mode 100644
index 0000000000..8f72741387
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg_1.7.3.bb
@@ -0,0 +1,19 @@
+require xorg-xserver-common.inc
+
+DESCRIPTION = "the X.Org X server"
+DEPENDS += "pixman libpciaccess openssl dri2proto glproto xorg-minimal-fonts"
+PE = "2"
+PR = "r1"
+
+SRC_URI += "file://sysroot_fix.patch;patch=1 \
+ file://dolt-fix-1.7.0.patch;patch=1 \
+ file://randr-support-1.7.0.patch;patch=1 \
+ "
+do_install_prepend() {
+ mkdir -p ${D}/${libdir}/X11/fonts
+}
+
+EXTRA_OECONF += "--disable-xephyr --disable-config-hal --disable-xinerama --disable-kdrive --disable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-dmx"
+EXTRA_OECONF += " --disable-glx-tls --enable-dri2 --disable-unit-tests "
+
+export LDFLAGS += " -ldl "