aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-driver
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xorg-driver')
-rw-r--r--recipes/xorg-driver/xf86-input-evdev_2.3.0.bb1
-rw-r--r--recipes/xorg-driver/xf86-input-evdev_2.3.2.bb4
-rw-r--r--recipes/xorg-driver/xf86-input-synaptics_1.2.1.bb4
-rw-r--r--recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch22
-rw-r--r--recipes/xorg-driver/xf86-input-tslib_0.0.6.bb4
-rw-r--r--recipes/xorg-driver/xf86-video-nv_2.1.16.bb4
6 files changed, 37 insertions, 2 deletions
diff --git a/recipes/xorg-driver/xf86-input-evdev_2.3.0.bb b/recipes/xorg-driver/xf86-input-evdev_2.3.0.bb
index 9160df5b6e..1e66108501 100644
--- a/recipes/xorg-driver/xf86-input-evdev_2.3.0.bb
+++ b/recipes/xorg-driver/xf86-input-evdev_2.3.0.bb
@@ -4,4 +4,3 @@ DESCRIPTION = "X.Org X server -- evdev input driver"
PE = "1"
DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_shr = "1"
diff --git a/recipes/xorg-driver/xf86-input-evdev_2.3.2.bb b/recipes/xorg-driver/xf86-input-evdev_2.3.2.bb
new file mode 100644
index 0000000000..792909621a
--- /dev/null
+++ b/recipes/xorg-driver/xf86-input-evdev_2.3.2.bb
@@ -0,0 +1,4 @@
+require xorg-driver-input.inc
+
+DESCRIPTION = "X.Org X server -- evdev input driver"
+PE = "1"
diff --git a/recipes/xorg-driver/xf86-input-synaptics_1.2.1.bb b/recipes/xorg-driver/xf86-input-synaptics_1.2.1.bb
new file mode 100644
index 0000000000..e6325675f8
--- /dev/null
+++ b/recipes/xorg-driver/xf86-input-synaptics_1.2.1.bb
@@ -0,0 +1,4 @@
+require xorg-driver-input.inc
+
+DESCRIPTION = "X.Org X server -- mouse input driver"
+PE = "1"
diff --git a/recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch b/recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch
new file mode 100644
index 0000000000..e989717d3b
--- /dev/null
+++ b/recipes/xorg-driver/xf86-input-tslib/dontfloodevents006.patch
@@ -0,0 +1,22 @@
+Index: xf86-input-tslib-0.0.6/src/tslib.c
+===================================================================
+--- xf86-input-tslib-0.0.6.orig/src/tslib.c 2009-11-29 20:03:29.734794324 +0000
++++ xf86-input-tslib-0.0.6/src/tslib.c 2009-11-29 20:29:24.066794215 +0000
+@@ -205,7 +205,7 @@
+ */
+ switch (priv->state) {
+ case BUTTON_EMULATION_OFF :
+- if(priv->lastp != samp.pressure) {
++ if(!!priv->lastp != !!samp.pressure) {
+ priv->lastp = samp.pressure;
+ xf86PostButtonEvent(local->dev, TRUE,
+ 1, !!samp.pressure, 0, 2,
+@@ -512,7 +512,7 @@
+ s = xf86CheckStrOption(dev->commonOptions, "path", NULL);
+ if (!s)
+ s = xf86CheckStrOption(dev->commonOptions, "Device", NULL);
+-
++
+ priv->ts = ts_open(s, 1);
+ xfree(s);
+
diff --git a/recipes/xorg-driver/xf86-input-tslib_0.0.6.bb b/recipes/xorg-driver/xf86-input-tslib_0.0.6.bb
index 785e5f4e5e..e86f0c75e6 100644
--- a/recipes/xorg-driver/xf86-input-tslib_0.0.6.bb
+++ b/recipes/xorg-driver/xf86-input-tslib_0.0.6.bb
@@ -4,7 +4,10 @@ DESCRIPTION = "X.Org X server -- tslib input driver"
RRECOMMENDS += "hal tslib-calibrate"
DEPENDS += "tslib"
+PR = "r2"
+
SRC_URI = "http://www.pengutronix.de/software/xf86-input-tslib/download/xf86-input-tslib-${PV}.tar.bz2 \
+ file://dontfloodevents006.patch;patch=1 \
file://10-x11-input-tslib.fdi"
do_configure_prepend() {
@@ -17,4 +20,3 @@ do_install_append() {
}
FILES_${PN} += "${datadir}/hal"
-
diff --git a/recipes/xorg-driver/xf86-video-nv_2.1.16.bb b/recipes/xorg-driver/xf86-video-nv_2.1.16.bb
new file mode 100644
index 0000000000..0d4ee2ed19
--- /dev/null
+++ b/recipes/xorg-driver/xf86-video-nv_2.1.16.bb
@@ -0,0 +1,4 @@
+require xorg-driver-video.inc
+
+DESCRIPTION = "X.Org X server -- NV display driver"
+PE = "1"