aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb')
-rw-r--r--recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb b/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
new file mode 100644
index 0000000000..4091e1ffd9
--- /dev/null
+++ b/recipes/xmlrpc-c/xmlrpc-c_1.06.41.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \
+write an XML-RPC server or client in C or C++."
+LICENSE = "GPLv2+"
+DEPENDS = "curl libxml2"
+PR = "r0"
+
+# note: this is version 1.06.47
+# there seems to be versions with higher numbers (e.g. 1.11.00)
+# but these are actually not newer
+
+EXTRA_OECONF = " --enable-libxml2-backend -disable-libwww-client"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tgz"
+SRC_URI[md5sum] = "02c6b89b8ff911341b6b6d4a6c621ea9"
+SRC_URI[sha256sum] = "a13f5ef40ed75d89543b9cd086185121dead9fc7de850ca4d2edd9a0cec12205"
+