aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/xfce4-panel_4.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xfce-base/xfce4-panel_4.6.1.bb')
-rw-r--r--recipes/xfce-base/xfce4-panel_4.6.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xfce-base/xfce4-panel_4.6.1.bb b/recipes/xfce-base/xfce4-panel_4.6.1.bb
new file mode 100644
index 0000000000..c19d6fdd48
--- /dev/null
+++ b/recipes/xfce-base/xfce4-panel_4.6.1.bb
@@ -0,0 +1,31 @@
+# xfce4-panel OE build file
+
+DESCRIPTION = "Xfce4 Panel"
+DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
+SECTION = "x11"
+PR = "r2"
+
+inherit xfce46
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"