aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/wolf3d/wolf4sdl_1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/wolf3d/wolf4sdl_1.6.bb')
-rw-r--r--recipes/wolf3d/wolf4sdl_1.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/wolf3d/wolf4sdl_1.6.bb b/recipes/wolf3d/wolf4sdl_1.6.bb
new file mode 100644
index 0000000000..2e3483b164
--- /dev/null
+++ b/recipes/wolf3d/wolf4sdl_1.6.bb
@@ -0,0 +1,17 @@
+LICENSE = "Various"
+DESCRIPTION = "Wolfenstein3d game engine"
+DEPENDS = "virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://www.stud.uni-karlsruhe.de/~uvaue/chaos/bins/Wolf4SDL-${PV}-src.zip"
+
+S = "${WORKDIR}/Wolf4SDL-1.6-src"
+
+TARGET_CFLAGS_append = " -lSDL -lSDL_mixer -I${STAGING_INCDIR} -I${STAGING_INCDIR}/SDL"
+
+do_compile() {
+ oe_runmake -e Q= PREFIX=${prefix}
+}
+
+do_install() {
+ oe_runmake -e Q= PREFIX=${D}/${prefix} install
+}