aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/watchdog
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/watchdog')
-rw-r--r--recipes/watchdog/watchdog_5.6.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/watchdog/watchdog_5.6.bb b/recipes/watchdog/watchdog_5.6.bb
new file mode 100644
index 0000000000..6c8bd56e73
--- /dev/null
+++ b/recipes/watchdog/watchdog_5.6.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "System watchdog daemon"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
+ file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "watchdog"
+INITSCRIPT_PARAMS = "defaults 10"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
+}
+