aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlan/vlan_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vlan/vlan_1.9.bb')
-rw-r--r--recipes/vlan/vlan_1.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/vlan/vlan_1.9.bb b/recipes/vlan/vlan_1.9.bb
new file mode 100644
index 0000000000..3a10e898ab
--- /dev/null
+++ b/recipes/vlan/vlan_1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "802.1q vlan support program"
+RRECOMMENDS = "kernel-module-8021q"
+PR = "r0"
+
+S = "${WORKDIR}/vlan/"
+
+SRC_URI = "http://www.candelatech.com/~greear/vlan/vlan.${PV}.tar.gz \
+ "
+
+inherit base
+
+CCFLAGS = "-g -D_GNU_SOURCE -Wall -I${STAGING_INCDIR}"
+LDLIBS = ""
+
+do_compile() {
+ ${CC} ${CCFLAGS} -c vconfig.c
+ ${CC} ${CCFLAGS} ${LDFLAGS} -o vconfig vconfig.o ${LDLIBS}
+}
+
+do_install() {
+ install -d "${D}${sbindir}"
+ install -m 755 "${S}/vconfig" "${D}${sbindir}/vconfig"
+}
+