aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/vlan/vlan_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/vlan/vlan_1.8.bb')
-rw-r--r--recipes/vlan/vlan_1.8.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/vlan/vlan_1.8.bb b/recipes/vlan/vlan_1.8.bb
new file mode 100644
index 0000000000..2b8d1d18a8
--- /dev/null
+++ b/recipes/vlan/vlan_1.8.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "802.1q vlan support program"
+RRECOMMENDS = "kernel-module-8021q"
+PR = "r2"
+
+S = "${WORKDIR}/vlan/"
+
+SRC_URI = "http://scry.wanfear.com/~greear/vlan/vlan.1.8.tar.gz \
+ "
+
+inherit base
+
+CCFLAGS = "-g -D_GNU_SOURCE -Wall -I${STAGING_INCDIR}"
+LDLIBS = ""
+
+do_compile() {
+ ${CC} ${CCFLAGS} -c vconfig.c
+ ${CC} ${CCFLAGS} ${LDFLAGS} -o vconfig vconfig.o ${LDLIBS}
+ ${STRIP} vconfig
+}
+
+do_install() {
+ install -d "${D}/usr/sbin"
+ install -m 755 "${S}/vconfig" "${D}/usr/sbin/vconfig"
+}
+