aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/viking/viking-0.9.6/viking-parallel-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/viking/viking-0.9.6/viking-parallel-build.patch')
-rw-r--r--recipes/viking/viking-0.9.6/viking-parallel-build.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/viking/viking-0.9.6/viking-parallel-build.patch b/recipes/viking/viking-0.9.6/viking-parallel-build.patch
new file mode 100644
index 0000000000..9b2244a06d
--- /dev/null
+++ b/recipes/viking/viking-0.9.6/viking-parallel-build.patch
@@ -0,0 +1,15 @@
+Index: viking-0.9.6/src/icons/Makefile.am
+===================================================================
+--- viking-0.9.6.orig/src/icons/Makefile.am 2008-07-27 20:25:34.000000000 +0000
++++ viking-0.9.6/src/icons/Makefile.am 2008-09-05 14:15:29.000000000 +0000
+@@ -134,8 +134,8 @@
+
+ .png.png_h:
+ gdk-pixbuf-csource --name="`basename $< .png`" --struct --extern $< > $@
+- cat $@ | sed -e 's/\(pixel_data: ..\)/\1 (unsigned char \*)/' > temp.h
+- mv temp.h $@
++ cat $@ | sed -e 's/\(pixel_data: ..\)/\1 (unsigned char \*)/' > temp$@.h
++ mv temp$@.h $@
+
+ INCLUDES = @GTK_CFLAGS@
+ AM_CFLAGS = -Wall -g -D_GNU_SOURCE