aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/uqm/uqm_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/uqm/uqm_0.5.0.bb')
-rw-r--r--recipes/uqm/uqm_0.5.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/uqm/uqm_0.5.0.bb b/recipes/uqm/uqm_0.5.0.bb
new file mode 100644
index 0000000000..089922a472
--- /dev/null
+++ b/recipes/uqm/uqm_0.5.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Star Control 2 source port using SDL (see sc2.sourceforge.net)"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-net libvorbis libogg zlib"
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r2"
+
+S = "${WORKDIR}/uqm-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sc2/uqm-${PV}-source.tar.gz \
+ file://build-opts.sh \
+ file://build-oe.patch;patch=1;pnum=0 \
+"
+
+do_configure() {
+ install ${WORKDIR}/build-opts.sh ${S}/
+ ./build-opts.sh ${STAGING_DIR_HOST}${layout_prefix} ${STAGING_BINDIR} ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ export ARCH="${TARGET_ARCH}"
+ export CC="${CC}"
+ export STAGING_INCDIR="${STAGING_INCDIR}"
+ export STAGING_LIBDIR="${STAGING_LIBDIR}"
+ ./build.sh uqm
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 uqm ${D}${bindir}
+}