aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unzip/unzip_552.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/unzip/unzip_552.bb')
-rw-r--r--recipes/unzip/unzip_552.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/unzip/unzip_552.bb b/recipes/unzip/unzip_552.bb
new file mode 100644
index 0000000000..2f06e1b1c6
--- /dev/null
+++ b/recipes/unzip/unzip_552.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A (de)compression library for the ZIP format"
+SECTION = "console/utils"
+LICENSE = "Info-ZIP"
+PR = "r1"
+
+SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
+S = "${WORKDIR}/unzip-5.52"
+
+export LD = "${CC}"
+
+do_compile() {
+ oe_runmake -f unix/Makefile generic
+}
+
+do_install() {
+ oe_runmake -f unix/Makefile install prefix=${D}${prefix}
+ install -d ${D}${mandir}
+ mv ${D}${prefix}/man/* ${D}${mandir}
+}
+
+