aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/unifdef/unifdef-native_2.6.18+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/unifdef/unifdef-native_2.6.18+git.bb')
-rw-r--r--recipes/unifdef/unifdef-native_2.6.18+git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/unifdef/unifdef-native_2.6.18+git.bb b/recipes/unifdef/unifdef-native_2.6.18+git.bb
new file mode 100644
index 0000000000..f2992ca709
--- /dev/null
+++ b/recipes/unifdef/unifdef-native_2.6.18+git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Kernel header preprocessor"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "file://unifdef.c"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o unifdef ${WORKDIR}/unifdef.c
+}
+
+do_stage() {
+ install -m 0755 unifdef ${STAGING_BINDIR}
+}
+
+do_install() {
+ :
+}
+