aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot')
-rw-r--r--recipes/u-boot/u-boot_2009.03.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_2009.03.bb b/recipes/u-boot/u-boot_2009.03.bb
index 2b65948b6c..7749aea61e 100644
--- a/recipes/u-boot/u-boot_2009.03.bb
+++ b/recipes/u-boot/u-boot_2009.03.bb
@@ -4,6 +4,8 @@ require u-boot.inc
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_hipox = "1"
+DEPENDS_append_hipox = " oxnas-boot-tools oxnas-boot-tools-native "
+
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
SRC_URI_append_hipox = "file://00-hipox.patch;patch=1 \
@@ -24,5 +26,10 @@ do_compile () {
oe_runmake all
}
+do_deploy_append_hipox () {
+ cat ${STAGING_DATADIR}/oxnas-boot-tools/arm/oxnasbt_header.bin ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE} > ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}.wrapped
+ oxnasbt_update_header ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}.wrapped
+}
+
SRC_URI[md5sum] = "285e2184d2efef50e0fe43b71d2a7b11"
SRC_URI[sha256sum] = "a2889bee9c45575b284564dbc27cf3dc6cb9833d4ff643976a1b3dba2d763f86"