aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-utils-native_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/u-boot-utils-native_1.2.0.bb')
-rw-r--r--recipes/u-boot/u-boot-utils-native_1.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-utils-native_1.2.0.bb b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
new file mode 100644
index 0000000000..b04b366ffe
--- /dev/null
+++ b/recipes/u-boot/u-boot-utils-native_1.2.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "U-boot bootloader mkimage utility"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+ALLOW_EMPTY = "1"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+inherit native
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ oe_runmake Sandpoint8240_config
+ oe_runmake tools
+}
+
+# install mkimage for the kernel makefile
+do_stage() {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/
+}
+