aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch')
-rw-r--r--recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch b/recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch
new file mode 100644
index 0000000000..eca50615ad
--- /dev/null
+++ b/recipes/u-boot/files/uboot-20070311-tools_makefile_ln_sf.patch
@@ -0,0 +1,26 @@
+Index: git/tools/Makefile
+===================================================================
+--- git.orig/tools/Makefile 2008-03-03 13:32:32.000000000 +0800
++++ git/tools/Makefile 2008-03-03 13:40:23.000000000 +0800
+@@ -208,18 +208,18 @@
+
+ $(obj)environment.c:
+ @rm -f $(obj)environment.c
+- ln -s $(src)../common/environment.c $(obj)environment.c
++ ln -sf $(src)../common/environment.c $(obj)environment.c
+
+ $(obj)environment.o: $(obj)environment.c
+ $(CC) -g $(HOST_ENVIRO_CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ $(obj)crc32.c:
+ @rm -f $(obj)crc32.c
+- ln -s $(src)../lib_generic/crc32.c $(obj)crc32.c
++ ln -sf $(src)../lib_generic/crc32.c $(obj)crc32.c
+
+ $(obj)sha1.c:
+ @rm -f $(obj)sha1.c
+- ln -s $(src)../lib_generic/sha1.c $(obj)sha1.c
++ ln -sf $(src)../lib_generic/sha1.c $(obj)sha1.c
+
+ $(LOGO_H): $(obj)bmp_logo $(LOGO_BMP)
+ $(obj)./bmp_logo $(LOGO_BMP) >$@