aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-xdctools-native_3.15.01.59.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-xdctools-native_3.15.01.59.bb')
-rw-r--r--recipes/ti/ti-xdctools-native_3.15.01.59.bb20
1 files changed, 7 insertions, 13 deletions
diff --git a/recipes/ti/ti-xdctools-native_3.15.01.59.bb b/recipes/ti/ti-xdctools-native_3.15.01.59.bb
index d06cb8f615..ee34a5eec2 100644
--- a/recipes/ti/ti-xdctools-native_3.15.01.59.bb
+++ b/recipes/ti/ti-xdctools-native_3.15.01.59.bb
@@ -1,22 +1,16 @@
inherit native
-require ti-xdctools.inc
-
-SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/rtsc/xdctools_3_15//exports/xdctools_setuplinux_3_15_01_59.bin"
-BINFILE = "xdctools_setuplinux_3_15_01_59.bin"
-S = "${WORKDIR}/xdctools_3_15_01_59"
+BASE_PV = "3_15"
+PV = "3_15_01_59"
-# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "315"
-PR = "r4"
+require ti-xdctools.inc
do_stage() {
- install -d -m 0755 ${STAGING_DIR_NATIVE}/${PN}
+ install -d ${STAGING_DIR_NATIVE}/${PN}
cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}
- chmod 755 -R ${STAGING_DIR_NATIVE}/${PN}
- # rm_work fails if you don't chmod S:
- chmod 755 -R ${S}
+ chmod 755 -R ${STAGING_DIR_NATIVE}/${PN}
+ chmod 755 -R ${S}
}
-AUTOTOOLS_NATIVE_STAGE_INSTALL = "1"
+AUTOTOOLS_NATIVE_STAGE_INSTALL="1"