aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-dspbios-native_5.33.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-dspbios-native_5.33.02.bb')
-rw-r--r--recipes/ti/ti-dspbios-native_5.33.02.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/ti/ti-dspbios-native_5.33.02.bb b/recipes/ti/ti-dspbios-native_5.33.02.bb
new file mode 100644
index 0000000000..9e224434c4
--- /dev/null
+++ b/recipes/ti/ti-dspbios-native_5.33.02.bb
@@ -0,0 +1,21 @@
+require ti-dspbios.inc
+inherit native
+
+# download bios_setuplinux_5_33_02.bin from https://www-a.ti.com/downloads/sds_support/targetcontent/bios/bios_5_33/bios_5_33_02/index_external.html and copy in Arago (or OE) installation directory
+
+SRC_URI = "http://install.source.dir.com/bios_setuplinux_5_33_02.bin"
+BINFILE="bios_setuplinux_5_33_02.bin"
+
+S = "${WORKDIR}/bios_5_33_02"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "5332"
+PR = "r14"
+
+do_stage() {
+ install -d ${STAGING_DIR_NATIVE}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR_NATIVE}/${PN}/
+}
+
+AUTOTOOLS_NATIVE_STAGE_INSTALL="1"
+