aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti/ti-codecs-omapl137_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti/ti-codecs-omapl137_1.0.bb')
-rw-r--r--recipes/ti/ti-codecs-omapl137_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ti/ti-codecs-omapl137_1.0.bb b/recipes/ti/ti-codecs-omapl137_1.0.bb
new file mode 100644
index 0000000000..269f9a3e00
--- /dev/null
+++ b/recipes/ti/ti-codecs-omapl137_1.0.bb
@@ -0,0 +1,23 @@
+require ti-codec.inc
+
+# Should be replaced with real http URL, but for now create codec combo tar from DVSDK installation.
+SRC_URI = "http://install.source.dir.local/omapl137_dvsdk_combos_1_0.tar.gz"
+
+S = "${WORKDIR}/omapl137_dvsdk_combos_1_0"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "1_0"
+PR = "r1"
+
+do_compile() {
+ echo "do nothing"
+}
+
+do_install () {
+ install -d ${D}/${installdir}/codec-combo
+ cd ${S}
+ for file in `find . -name *.x64P`; do
+ cp ${file} ${D}/${installdir}/codec-combo
+ done
+}
+