aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcpdump/files/ipv6-cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tcpdump/files/ipv6-cross.patch')
-rw-r--r--recipes/tcpdump/files/ipv6-cross.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/tcpdump/files/ipv6-cross.patch b/recipes/tcpdump/files/ipv6-cross.patch
new file mode 100644
index 0000000000..54e20ae9eb
--- /dev/null
+++ b/recipes/tcpdump/files/ipv6-cross.patch
@@ -0,0 +1,37 @@
+Index: tcpdump-4.0.0/configure.in
+===================================================================
+--- tcpdump-4.0.0.orig/configure.in
++++ tcpdump-4.0.0/configure.in
+@@ -160,8 +160,9 @@ yes) AC_MSG_RESULT(yes)
+ ipv6=no
+ ;;
+ esac ],
+-
+- AC_TRY_RUN([ /* AF_INET6 available check */
++[
++ if test x"$cross_compiling" != "xyes"; then
++ AC_TRY_RUN([ /* AF_INET6 avalable check */
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ main()
+@@ -180,7 +181,10 @@ main()
+ ipv6=no],
+ [ AC_MSG_RESULT(no)
+ ipv6=no]
+-))
++ )
++else
++ AC_MSG_FAILURE([Unable to check for ipv6 when crosscompiling, please specify.])
++fi])
+
+ ipv6type=unknown
+ ipv6lib=none
+@@ -295,7 +299,7 @@ if test "$ipv6" = "yes" -a "$ipv6lib" !=
+ fi
+
+
+-if test "$ipv6" = "yes"; then
++if test x"$cross_compiling" != "xyes" -a "$ipv6" = "yes"; then
+ #
+ # XXX - on Tru64 UNIX 5.1, there is no "getaddrinfo()"
+ # function in libc; there are "ngetaddrinfo()" and