aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tcltk
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tcltk')
-rw-r--r--recipes/tcltk/tcl_8.5.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/tcltk/tcl_8.5.8.bb b/recipes/tcltk/tcl_8.5.8.bb
index 86302407c7..e98b98d29d 100644
--- a/recipes/tcltk/tcl_8.5.8.bb
+++ b/recipes/tcltk/tcl_8.5.8.bb
@@ -25,10 +25,14 @@ inherit autotools binconfig
EXTRA_OECONF = "--enable-threads"
-do_compile_prepend() {
+do_configure_append() {
echo > ../compat/fixstrtod.c
+}
+
+do_compile_prepend_pn-tcl () {
sed -i -e 's:./tclsh :tclsh :g' Makefile
}
+
do_install() {
autotools_do_install
# Stage a few extra headers to make tk happy