aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tasks/task-slugos-toolchain-target.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tasks/task-slugos-toolchain-target.bb')
-rw-r--r--recipes/tasks/task-slugos-toolchain-target.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/tasks/task-slugos-toolchain-target.bb b/recipes/tasks/task-slugos-toolchain-target.bb
new file mode 100644
index 0000000000..489a41213b
--- /dev/null
+++ b/recipes/tasks/task-slugos-toolchain-target.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Packages for a standalone SDK or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r1"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a SlugOS image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ libgcc \
+ linux-libc-headers-dev \
+ libssl \
+ libcrypto \
+ openssl-dev \
+ libstdc++ \
+ "
+
+# Not sure if we need these or not...
+NOT_SURE_ABOUT = "\
+ libsegfault \
+ "
+
+# This one needs further investigation; seems to be some sort
+# of naming problem that breaks the SDK when it is added directly.
+ODDLY_BROKEN_PACKAGES ="\
+ libz-dev \
+ "