aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/swfdec/swfdec_0.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/swfdec/swfdec_0.4.0.bb')
-rw-r--r--recipes/swfdec/swfdec_0.4.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/swfdec/swfdec_0.4.0.bb b/recipes/swfdec/swfdec_0.4.0.bb
new file mode 100644
index 0000000000..c9296c652b
--- /dev/null
+++ b/recipes/swfdec/swfdec_0.4.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Swfdec is a decoder/renderer for Macromedia Flash animations."
+LICENSE = "LGPL"
+
+DEPENDS = "pango cairo liboil zlib gtk+ alsa-lib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+PR = "r1"
+
+SRC_URI = "http://swfdec.freedesktop.org/download/swfdec/0.4/${P}.tar.gz \
+ file://jsautocfg.h \
+ file://fix-cross-build.patch;patch=1"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_append() {
+ cp -f ${WORKDIR}/jsautocfg.h ${S}/libswfdec/js
+}
+