aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/subversion/subversion_1.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/subversion/subversion_1.4.5.bb')
-rw-r--r--recipes/subversion/subversion_1.4.5.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes/subversion/subversion_1.4.5.bb b/recipes/subversion/subversion_1.4.5.bb
index d4f290590f..1029e70c5c 100644
--- a/recipes/subversion/subversion_1.4.5.bb
+++ b/recipes/subversion/subversion_1.4.5.bb
@@ -9,7 +9,8 @@ PR = "r0"
SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
file://disable-revision-install.patch;patch=1 \
- file://neon-detection.patch;patch=1"
+ file://neon-detection.patch;patch=1 \
+ file://libtool.patch;patch=1"
EXTRA_OECONF = "--with-neon=${STAGING_EXECPREFIXDIR} \
--without-berkeley-db --without-apxs --without-apache \
@@ -23,6 +24,14 @@ export LDFLAGS += " -L${STAGING_LIBDIR} "
acpaths = "-I build/ -I build/ac-macros/"
+# FIXME: Ugly hack! Instead of fully porting to the new libtool, apply libtool.patch and do the rest here.
+do_configure_prepend() {
+ rm -f build/libtool.m4
+}
+do_configure_append() {
+ if ! test -f libtool ; then cp -a *-libtool libtool ; fi
+}
+
do_stage() {
autotools_stage_all
}