summaryrefslogtreecommitdiffstats
path: root/recipes/stopwatch/stopwatch_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/stopwatch/stopwatch_git.bb')
-rw-r--r--recipes/stopwatch/stopwatch_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/stopwatch/stopwatch_git.bb b/recipes/stopwatch/stopwatch_git.bb
new file mode 100644
index 0000000000..f0d40da54b
--- /dev/null
+++ b/recipes/stopwatch/stopwatch_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Simple Qt based stop watch"
+AUTHOR = "Christof Musik"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+HOMEPAGE = "http://git.senfdax.de"
+LICENSE = "GPL QPL"
+DEPENDS = "qt4-x11-free"
+PV = "1.3.1+gitr${SRCREV}"
+PR = "r0"
+
+inherit qt4x11
+
+SRC_URI = "git://git.senfdax.de/git/stopwatch;protocol=http;tag=master;branch=master"
+S = "${WORKDIR}/git/"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}stopwatch ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install ${S}desktop/stopwatch.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install ${S}desktop/stopwatch.png ${D}${datadir}/pixmaps/
+ install -d ${D}${datadir}/${PN}
+ install ${S}desktop/om.style ${D}${datadir}/${PN}/
+}