aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/squashfs-tools/squashfs-tools_2.0r2.bb')
-rw-r--r--recipes/squashfs-tools/squashfs-tools_2.0r2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools_2.0r2.bb b/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
new file mode 100644
index 0000000000..25be0837d2
--- /dev/null
+++ b/recipes/squashfs-tools/squashfs-tools_2.0r2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
+DEPENDS = "lzma"
+SECTION = "base"
+LICENSE = "GPLv2"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
+ file://flags.patch;patch=1 \
+ file://squashfs2.0-tools-lzma.patch;patch=1"
+S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
+
+prefix = ""
+
+do_compile() {
+ oe_runmake
+ oe_runmake mksquashfs-lzma
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 mksquashfs-lzma ${D}${sbindir}/
+}