aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr')
-rw-r--r--recipes/shr/e-wm-config-illume-shr_git.bb11
-rw-r--r--recipes/shr/initscripts-shr/palmpre/usb-gadget.sh10
-rw-r--r--recipes/shr/initscripts-shr_0.0.1.bb8
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl2_git.bb2
-rw-r--r--recipes/shr/libframeworkd-phonegui-efl_git.bb2
-rw-r--r--recipes/shr/libphone-ui-shr_git.bb2
-rw-r--r--recipes/shr/phonefsod_git.bb3
-rw-r--r--recipes/shr/phoneuid_git.bb6
-rw-r--r--recipes/shr/shr-config_git.bb2
-rw-r--r--recipes/shr/shr-launcher_svn.bb25
-rw-r--r--recipes/shr/shr-wizard_git.bb2
11 files changed, 55 insertions, 18 deletions
diff --git a/recipes/shr/e-wm-config-illume-shr_git.bb b/recipes/shr/e-wm-config-illume-shr_git.bb
index 36154cef8e..76ce8d3071 100644
--- a/recipes/shr/e-wm-config-illume-shr_git.bb
+++ b/recipes/shr/e-wm-config-illume-shr_git.bb
@@ -3,7 +3,7 @@ SECTION = "e/utils"
DEPENDS = "eet"
LICENSE = "MIT BSD"
PV = "1.1-${EFL_SRCREV}+gitr${SRCPV}"
-PR = "r6"
+PR = "r7"
inherit e
@@ -17,5 +17,12 @@ EXTRA_OECONF = "\
FILES_${PN} = "${datadir}/enlightenment/data/config/illume-shr"
-RRECOMMENDS_${PN} = "e-wm-theme-illume-shr e-wm-sysactions-shr e-wm-menu-shr"
+RRECOMMENDS_${PN} = "\
+ e-wm-theme-illume-shr \
+ e-wm-sysactions-shr \
+ e-wm-menu-shr \
+ illume-keyboard-default-alpha \
+ illume-keyboard-default-numeric \
+ illume-keyboard-default-terminal \
+"
diff --git a/recipes/shr/initscripts-shr/palmpre/usb-gadget.sh b/recipes/shr/initscripts-shr/palmpre/usb-gadget.sh
new file mode 100644
index 0000000000..d7554954d6
--- /dev/null
+++ b/recipes/shr/initscripts-shr/palmpre/usb-gadget.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# usb gadget configuration:
+# there already different configurations on the palm pre defined,
+# we choose nr 5 cause it provides the usbnet, novacom
+# and storage gadget
+if [ -e /sys/class/usb_gadget/config_num ]; then
+ echo 5 > /sys/class/usb_gadget/config_num
+fi
+
diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
index f1be1c2fc7..89df6ce375 100644
--- a/recipes/shr/initscripts-shr_0.0.1.bb
+++ b/recipes/shr/initscripts-shr_0.0.1.bb
@@ -5,7 +5,7 @@ DEPENDS = ""
RDEPENDS = ""
LICENSE = "GPL"
PV = "0.0.1"
-PR = "r13"
+PR = "r14"
RPROVIDES_${PN} = "initscripts"
RCONFLICTS_${PN} = "initscripts"
@@ -33,6 +33,7 @@ SRC_URI = "file://alignment.sh \
file://umountfs \
file://umountnfs.sh \
"
+SRC_URI_append_palmpre = " file://usb-gadget.sh"
inherit base
@@ -76,6 +77,11 @@ do_install () {
install -m 0755 ${WORKDIR}/umountfs ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/umountnfs.sh ${D}${sysconfdir}/init.d
+ if [ "${MACHINE}" == "palmpre" ]; then
+ install -m 0755 ${WORKDIR}/usb-gadget.sh ${D}${sysconfdir}/init.d
+ ln -sf ../init.d/usb-gadget.sh ${D}${sysconfdir}/rcS.d/S00usb-gadget.sh
+ fi
+
#
# Create runlevel links
#
diff --git a/recipes/shr/libframeworkd-phonegui-efl2_git.bb b/recipes/shr/libframeworkd-phonegui-efl2_git.bb
index cb1feade68..4d6f2c2eef 100644
--- a/recipes/shr/libframeworkd-phonegui-efl2_git.bb
+++ b/recipes/shr/libframeworkd-phonegui-efl2_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "frameworkd EFL phonegui 2"
SECTION = "e/apps"
DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
PV = "0.0.1+gitr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://shr.bearstech.com/repo/libframeworkd-phonegui-efl2.git;protocol=http;branch=master"
S = "${WORKDIR}/git"
diff --git a/recipes/shr/libframeworkd-phonegui-efl_git.bb b/recipes/shr/libframeworkd-phonegui-efl_git.bb
index c4181cf345..aa2070c2c7 100644
--- a/recipes/shr/libframeworkd-phonegui-efl_git.bb
+++ b/recipes/shr/libframeworkd-phonegui-efl_git.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
SECTION = "e/apps"
DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
PV = "0.0.3+gitr${SRCPV}"
-PR = "r35"
+PR = "r36"
require libframeworkd-phonegui-efl-theme.inc
diff --git a/recipes/shr/libphone-ui-shr_git.bb b/recipes/shr/libphone-ui-shr_git.bb
index fcc076f237..08320fe5d2 100644
--- a/recipes/shr/libphone-ui-shr_git.bb
+++ b/recipes/shr/libphone-ui-shr_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "SHR default module for the Phone UI daemon"
SECTION = "e/apps"
DEPENDS += " dbus-glib libframeworkd-glib libphone-ui etk evas ecore edje edje-native elementary"
PV = "0.0.0+gitr${SRCPV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://shr.bearstech.com/repo/libphone-ui-shr.git;protocol=http;branch=master"
S = "${WORKDIR}/git"
diff --git a/recipes/shr/phonefsod_git.bb b/recipes/shr/phonefsod_git.bb
index e35cbf7649..2103122068 100644
--- a/recipes/shr/phonefsod_git.bb
+++ b/recipes/shr/phonefsod_git.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
SECTION = "x11/applications"
DEPENDS += " dbus-glib libframeworkd-glib sqlite3 shr-specs"
PV = "0.0.0+gitr${SRCPV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://git.shr-project.org/repo/phonefsod.git;protocol=http;branch=master"
S = "${WORKDIR}/git"
@@ -18,5 +18,6 @@ EXTRA_OECONF = "\
SPECS_PATH=${STAGING_DATADIR}/shr-specs \
"
+CONFFILES_${PN} = "${sysconfdir}/phonefsod.conf"
diff --git a/recipes/shr/phoneuid_git.bb b/recipes/shr/phoneuid_git.bb
index e786d3e4cd..603a1d1609 100644
--- a/recipes/shr/phoneuid_git.bb
+++ b/recipes/shr/phoneuid_git.bb
@@ -4,7 +4,9 @@ LICENSE = "GPL"
SECTION = "x11/applications"
DEPENDS += " dbus-glib libframeworkd-glib libphone-ui sqlite3 shr-specs"
PV = "0.0.0+gitr${SRCPV}"
-PR = "r3"
+PR = "r5"
+
+RREPLACES_${PN} = "shr-today"
SRC_URI = "git://git.shr-project.org/repo/phoneuid.git;protocol=http;branch=master"
S = "${WORKDIR}/git"
@@ -18,3 +20,5 @@ EXTRA_OECONF = "\
FILES_${PN} += "${datadir}"
+CONFFILES_${PN} = "${sysconfdir}/phoneuid.conf"
+
diff --git a/recipes/shr/shr-config_git.bb b/recipes/shr/shr-config_git.bb
index cc8d685a27..b1fddd8246 100644
--- a/recipes/shr/shr-config_git.bb
+++ b/recipes/shr/shr-config_git.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
DEPENDS = "vala-native elementary libeflvala"
SECTION = "x11/application"
PV = "0.0.2+gitr${SRCPV}"
-PR = "r4"
+PR = "r5"
EXTRA_OECONF="--enable-vapidir=${STAGING_DATADIR}/vala/vapi"
inherit autotools
diff --git a/recipes/shr/shr-launcher_svn.bb b/recipes/shr/shr-launcher_svn.bb
index ffd6161586..481be9021b 100644
--- a/recipes/shr/shr-launcher_svn.bb
+++ b/recipes/shr/shr-launcher_svn.bb
@@ -6,16 +6,25 @@ SECTION = "e/apps"
DEPENDS = "elementary eina edbus"
PV = "0.0.1+svnr${SRCPV}"
-PR = "r0"
+PR = "r4"
-SRC_URI = "svn://shr-launcher.googlecode.com/svn/trunk;module=.;proto=http"
+SRC_URI = "svn://shr-launcher.googlecode.com/svn;module=trunk;proto=http"
-do_configure_prepend() {
- rm -f ${S}/config.log
- rm -f ${S}/config.status
-}
-
-S = "${WORKDIR}"
+S = "${WORKDIR}/trunk"
inherit autotools
+do_install_append() {
+ install -d "${D}/${datadir}/pixmaps"
+ install -m 0644 "${S}/resources/launcher.png" "${D}/${datadir}/pixmaps"
+ install -d "${D}/${datadir}/applications"
+ install -m 0644 "${S}/resources/launcher.desktop" "${D}/${datadir}/applications"
+ install -d "${D}/${datadir}/launcher"
+ for ico in "${S}/resources/"*.png; do
+ if [ "$(basename $ico)" != "launcher.png" ]; then
+ install -m 0644 $ico "${D}/${datadir}/launcher"
+ fi
+ done
+}
+
+FILES_${PN} += "/usr/share/launcher/* /usr/share/applications/* /usr/share/pixmaps/*"
diff --git a/recipes/shr/shr-wizard_git.bb b/recipes/shr/shr-wizard_git.bb
index ec63fb13fc..33bac9d234 100644
--- a/recipes/shr/shr-wizard_git.bb
+++ b/recipes/shr/shr-wizard_git.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://shr-project.org"
LICENSE = "GPL"
RDEPENDS = "python-elementary shr-settings python-phoneutils e-wm python-dbus python-edbus"
SECTION = "x11/application"
-PV = "0.0.0+gitr${SRCREV}"
+PV = "0.0.0+gitr${SRCPV}"
PR = "r1"
inherit autotools