aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/phonefsod_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr/phonefsod_git.bb')
-rw-r--r--recipes/shr/phonefsod_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/shr/phonefsod_git.bb b/recipes/shr/phonefsod_git.bb
new file mode 100644
index 0000000000..bc443a11a5
--- /dev/null
+++ b/recipes/shr/phonefsod_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "SHR Phone FSO Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib sqlite3 shr-specs"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/phonefsod.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "phonefsod"
+INITSCRIPT_PARAMS = "defaults 75"
+
+EXTRA_OECONF = "\
+ SPECS_PATH=${STAGING_DATADIR}/shr-specs \
+"
+
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0755 ${S}/data/phonefsod.init ${D}${sysconfdir}/init.d/phonefsod
+ install -m 0644 ${S}/data/phonefsod.conf ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${S}/data/etc-phonefsod.conf ${D}${sysconfdir}/phonefsod.conf
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+