aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb')
-rw-r--r--recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb b/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
new file mode 100644
index 0000000000..701915dbe3
--- /dev/null
+++ b/recipes/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Driver for the SHARP CG-AG06 digital compact flash camera for linux ${PV}"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+LICENSE = "CLOSED"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+PR = "r4"
+
+SRC_URI = "http://openzaurus.sf.net/mirror/camera-modules-2.4.18-rmk7-pxa3-embedix.tar.bz2 \
+ file://CE-AG06.dat \
+ file://sharpzdc \
+ file://sharpzdc.conf"
+S = "${WORKDIR}"
+
+COMPATIBLE_MACHINE = '(collie|poodle|tosa)'
+
+inherit module-base
+
+do_install() {
+ install -d ${D}${sysconfdir}/pcmcia/cis
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia
+ install -m 0644 ${WORKDIR}/CE-AG06.dat ${D}${sysconfdir}/pcmcia/cis/
+ install -m 0644 ${WORKDIR}/sharpzdc.conf ${D}${sysconfdir}/pcmcia/
+ install -m 0755 ${WORKDIR}/sharpzdc ${D}${sysconfdir}/pcmcia/
+ install -m 0644 ${MACHINE}/sharpzdc_cs.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
+}
+
+FILES_${PN} = "/"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"