aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/robostix-module/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/robostix-module/files/Makefile')
-rw-r--r--recipes/robostix-module/files/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/robostix-module/files/Makefile b/recipes/robostix-module/files/Makefile
new file mode 100644
index 0000000000..e242da4feb
--- /dev/null
+++ b/recipes/robostix-module/files/Makefile
@@ -0,0 +1,19 @@
+#############################################################################
+#
+# Makefile for building the robostix module
+#
+#############################################################################
+
+obj-m = robostix.o
+
+PWD = $(shell pwd)
+KBUILD_FLAGS = -C $(KERNEL_PATH) M=$(PWD) KERNELRELEASE=$(KERNELRELEASE)
+
+default: modules
+
+modules:
+ $(MAKE) $(KBUILD_FLAGS) modules
+
+clean:
+ rm -rf *.o *~ *.ko *.mod.c
+