aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qte/qte-mt-static_2.3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qte/qte-mt-static_2.3.10.bb')
-rw-r--r--recipes/qte/qte-mt-static_2.3.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/qte/qte-mt-static_2.3.10.bb b/recipes/qte/qte-mt-static_2.3.10.bb
new file mode 100644
index 0000000000..68ab2aceab
--- /dev/null
+++ b/recipes/qte/qte-mt-static_2.3.10.bb
@@ -0,0 +1,22 @@
+require qte-common_${PV}.inc
+PR = "r8"
+
+DEFAULT_PREFERENCE = "-1"
+
+EXTRA_OECONF += "-static -thread"
+
+do_stage() {
+ rm -rf ${STAGING_DIR_HOST}/qt2
+ install -d ${STAGING_DIR_HOST}/qt2/lib
+ oe_libinstall -a -C lib libqte-mt ${STAGING_DIR_HOST}/qt2/lib
+ rm -f include/qxt.h
+ install -d ${STAGING_DIR_HOST}/qt2/include
+ cp -pfLR include/* ${STAGING_DIR_HOST}/qt2/include
+ cp -pPR lib/fonts ${STAGING_DIR_HOST}/qt2/lib/
+}
+
+do_install() {
+ :
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"